Subject: [Pljava-dev] Pljava Build Failure Against PG 8.4

From: talha.rizwan at enterprisedb.com (Talha Rizwan)
Date: Tue, 2 Dec 2008 13:55:13 +0500

Hi,

Pljava-1.4.0 stops building after the following changes in PostgreSQL 8.4:

commit e53e76a8ebe64dbc8a64ec3dec5ba0
>
> 6f2e787f0b
> Author: Tom Lane <tgl at sss.pgh.pa.us>
> Date:   Wed Nov 19 01:10:24 2008 +0000
>
>    Some infrastructure changes for the upcoming auto-explain contrib
> module:
>        * Refactor explain.c slightly to export a convenient-to-use
> subroutine
>    for printing EXPLAIN results.
>        * Provide hooks for plugins to get control at ExecutorStart and
> ExecutorEnd
>    as well as ExecutorRun.
>        * Add some minimal support for tracking the total runtime of
> ExecutorRun.
>    This code won't actually do anything unless a plugin prods it to.
>        * Change the API of the DefineCustomXXXVariable functions to allow
> nonzero
>    "flags" to be specified for a custom GUC variable.  While at it, also
> make
>    the "bootstrap" default value for custom GUCs be explicitly specified as
> a
>    parameter to these functions.  This is to eliminate confusion over where
> the
>    default comes from, as has been expressed in the past by some users of
> the
>    custom-variable facility.
>        * Refactor GUC code a bit to ensure that a custom variable gets
> initialized    something valid (like its default value) even if the
> placeholder value was
>    invalid.

I've modified DefineCustomXXXVariable arguments by passing default values
for two new parameters i.e:

   - *NULL* for *const char *bootValue*
   - *0* for *int flags*

I've also added checks using *#ifdef* only for new arguments so that it
works on earlier version as well.

>> PFA *pljava-fix.patch* and do let me know if you find any problem in it.

--
Regards
Talha Bin Rizwan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20081202/e82d6691/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pljava-fix.patch
Type: text/x-diff
Size: 1951 bytes
Desc: not available
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20081202/e82d6691/attachment.bin>

---

From: books at ejurka.com (Kris Jurka)
Date: Mon, 9 Feb 2009 17:52:53 -0500 (EST)

> works on earlier version as well.

I've applied this fix to CVS.  One thing I changed was that for 
DefineCustom[Int|Bool]Variable, it wants an int or bool argument, not NULL 
for the default.

Kris Jurka