From: thomas at tada.se (Thomas Hallgren) Date: Thu, 07 Sep 2006 16:48:15 +0200 Subject: [Pljava-dev] LD_LIBRARY_PATH on Ubuntu In-Reply-To: <45001DE8.5000607@starjar.com> References: <45001DE8.5000607@starjar.com> Message-ID: Hi Peter, Perhaps Ubuntu is one of those systems that also need /opt/jdk1.5.0_08/jre/lib/i386/native_threads ? Something is definitely missing that prevents the JVM from loading. Regards, Thomas Hallgren Peter Henderson wrote: > Hi folks. > > > I'm trying to setup pljava with postgresql on unbuntu 6.06 (aka Dapper > Drake) on i386 > > I've managed to compile pljava, and copied the lib and jar to > /usr/share/pljava > > So far all is good. > > But whenever I try to run the deployer, I get an error > > peter at peter-desktop:~/downloads/java/postgres/pljava-1.3.0$ > ./deployer.sh -reinstall -host amd64 -database starjarpartech20060421 > -user peter -password secret > org.postgresql.util.PSQLException: ERROR: could not load library > "/usr/share/pljava/pljava.so": /usr/share/pljava/pljava.so: undefined > symbol: JNI_CreateJavaVM > at > org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:1512) > at > org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1297) > at > org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:188) > at > org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:437) > at > org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:339) > at > org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:331) > at > org.postgresql.pljava.deploy.Deployer.initJavaHandlers(Deployer.java:474) > at org.postgresql.pljava.deploy.Deployer.main(Deployer.java:269) > > > Which I assume means, postgresql cannot load the library. > > > So. > I modified > /etc/profile and added > export > LD_LIBRARY_PATH=/opt/jdk1.5.0_08/jre/lib/i386:/opt/jdk1.5.0_08/jre/lib/i386/client > > And I created > /etc/ld.so.conf > and put in it > # Peter Henderson > /opt/jdk1.5.0_08/jre/lib/i386 > /opt/jdk1.5.0_08/jre/lib/i386/client > > then ran > sudo su - > lddconfig > > restarted the postgresql service > /etc/init.d/postgresql-8.1 stop > /etc/init.d/postgresql-8.1 start > > yet the same problem. > > There must be something else Im missing?? > > > Peter Henderson