Subject: [postgresql-interfaces/psqlodbc] PR #103: chore: replace unsafe string-to-number conversions

From: "faviansamatha (@faviansamatha)" <[email-masked]>
Date: Tue, 08 Apr 2025 21:28:28 +0000

The following functions
```
atoi()
atol()
atoll()
atof()
```
have been deprecated by the `strto...` variants. 

This commit adds a new set of macros prefixed with `pg_` in `psqlodbc.h` to convert the `ato..()` calls to their respective `strto...` versions.

---

From: "faviansamatha (@faviansamatha)" <[email-masked]>
Date: Tue, 08 Apr 2025 22:57:20 +0000

Looks like the wix installation step failed in the github actions workflow. They released v6.0 a few days ago iirc.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Wed, 09 Apr 2025 12:40:39 +0000

Just rebase as I merged in a fix this morning https://github.com/postgresql-interfaces/psqlodbc/pull/104

---

From: "faviansamatha (@faviansamatha)" <[email-masked]>
Date: Wed, 09 Apr 2025 16:24:09 +0000

Done! Just rebased