Subject: [postgresql-interfaces/psqlodbc] issue #122: 17.00.0005 release showing version number of 17.00.0004

From: "simon-kempster (@simon-kempster)" <[email-masked]>
Date: Fri, 30 May 2025 10:42:56 +0000

For the latest release, in Windows, the Product Version on the DLLs is showing the version number of 17.00.0004, when it should be 17.00.0005.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Wed, 04 Jun 2025 15:15:21 +0000

Well, that's not good. Thanks for the report

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 05 Jun 2025 09:36:15 +0000

@chrullrich where does the version number of the dll get set in the WIX code ?

---

From: "chrullrich (@chrullrich)" <[email-masked]>
Date: Thu, 05 Jun 2025 10:03:16 +0000

It doesn't. The files are passed through unmodified, so the version resources have to be correct in them. WiX extracts the version number for its own purposes, too, but the way the installers work this does not prevent it from replacing the files with the new versions.

The display form of the version number did not update because 151feaa8080181a5ae0f9bc4d2211e5bd69e5539 replaced the macro POSTGRES_RESOURCE_VERSION in psqlodbc.rc with a literal "17.00.0004" in four places.

As to why the internal versions did not change even though psqlodbc.rc includes version.h, I currently have no idea. There may be something in the build procedure that did not get updated; version.h mentions that the versions may be overridden by command line arguments from psqlodbc.vcxproj, and it looks like that file uses the arguments. I have not yet found out where it takes their values from.

---

From: "chrullrich (@chrullrich)" <[email-masked]>
Date: Thu, 05 Jun 2025 11:25:05 +0000

> The display form of the version number did not update because [151feaa](https://github.com/postgresql-interfaces/psqlodbc/commit/151feaa8080181a5ae0f9bc4d2211e5bd69e5539) replaced the macro POSTGRES_RESOURCE_VERSION in psqlodbc.rc with a literal "17.00.0004" in four places.

The same happened to PG_DRVFILE_VERSION for the internal version numbers. It was changed to literal 17,0,0,4 in all four places it appears.