Subject: [postgresql-interfaces/psqlodbc] issue #127: Drop date from version message?

From: "df7cb (@df7cb)" <[email-masked]>
Date: Wed, 11 Jun 2025 16:16:32 +0000

https://github.com/postgresql-interfaces/psqlodbc/blob/251c8e8200c7a030fa46e59429d3fec7a73de4ec/connection.c#L1013-L1031

Could we drop the `__DATE__` there? It's making the build unreproducible (and if the build is reproducible, the build date is of little value). I've been patching this out in the Debian package since 2016 with no complaints: https://salsa.debian.org/postgresql/psqlodbc/-/blob/master/debian/patches/reproducible?ref_type=heads

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 12 Jun 2025 09:52:46 +0000

sure, I have no issues with this.

---

From: "df7cb (@df7cb)" <[email-masked]>
Date: Thu, 12 Jun 2025 12:05:58 +0000

Fix submitted as #128.