Subject: [postgresql-interfaces/psqlodbc] PR #13: Key caches based on software versions

From: "apgrucza (@apgrucza)" <[email-masked]>
Date: Sat, 11 May 2024 03:04:27 +0000

This fixes the problem of the cache action incorrectly causing steps to be skipped when software versions are updated.

Note that changing the commands inside a step will not prevent that step from being skipped, but this should not be a problem once the workflow is stable. If this does occur, it can be resolved by adding a suffix to the cache key to force the creation of a new cache.

---

From: "apgrucza (@apgrucza)" <[email-masked]>
Date: Sat, 11 May 2024 11:47:25 +0000

The failed workflow was due to [this bug](https://github.com/actions/cache/issues/1385) in `actions/cache`. I've renamed the necessary cache key to work around it.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Sat, 11 May 2024 20:33:12 +0000

testing failed ?

---

From: "apgrucza (@apgrucza)" <[email-masked]>
Date: Sat, 11 May 2024 21:46:43 +0000

> testing failed ?

See my comment above. Please rerun the workflow.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 13 May 2024 13:07:31 +0000

I noticed that you changed it so that we aren't downloading openssl64 anymore. 
We want to keep the versions of openssl the same so we need to download both 64 and 32 bit versions
EDB has version 3.0.13 of openssl

---

From: "apgrucza (@apgrucza)" <[email-masked]>
Date: Tue, 14 May 2024 00:30:09 +0000

> I noticed that you changed it so that we aren't downloading openssl64 anymore. We want to keep the versions of openssl the same so we need to download both 64 and 32 bit versions EDB has version 3.0.13 of openssl

@davecramer Yes, I was expecting you to merge those changes from your fork, which I see you've now done. After your changes, the other caching problem I mentioned in the description of  #13 has occurred and prevented the build of PostgreSQL, resulting in missing DLLs again. So I've created a new PR to address that here: #19