Subject: [postgresql-interfaces/psqlodbc] issue #133: Syntax error importing tables through Power Pivot in Excel

From: "spmcn (@spmcn)" <[email-masked]>
Date: Wed, 13 Aug 2025 12:56:33 +0000

I'm getting the following error when trying to import tables using Data Model (aka Power Pivot). This only occurs when trying to import through this Table Import wizard. 

<img width="528" height="568" alt="Image" src="https://github.com/user-attachments/assets/53c0cb8e-b3e3-47fb-947b-e11e6f2a3076" />

it's not unique to just that table, it happens with all my tables:

<img width="860" height="420" alt="Image" src="https://github.com/user-attachments/assets/4104320c-548b-4585-a6f8-7df44293135b" />

I can import okay through Power Query, so I know I'm connected to my database correctly. This only occurs through Power Pivot and Data Model.

I'm using:

- psqlodbc Release 17.00.0004 (32-bit)
- Microsoft® Excel® for Microsoft 365 MSO (Version 2505 Build 16.0.18827.20102) 32-bit

---

From: "spmcn (@spmcn)" <[email-masked]>
Date: Wed, 13 Aug 2025 13:07:32 +0000

I noticed that this only happens when I select "Add this data to the Data Model." So I can import one table at a time, but selecting multiple tables forces me to checkmark "Add this data to the Data Model" and that's when I get the error.

<img width="307" height="270" alt="Image" src="https://github.com/user-attachments/assets/20641d47-65b7-4355-8efe-75079907ace2" />

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Sat, 23 Aug 2025 10:25:14 +0000

Sorry for the late reply. I don't really know how to help you here. What version of ODBC are you using?