Subject: [postgresql-interfaces/psqlodbc] issue #136: Support application_name

From: "fjf2002 (@fjf2002)" <[email-masked]>
Date: Fri, 26 Sep 2025 09:21:13 +0000

Is it correct that currently there is no way to pass an Application Name in the connection string or elsewhere (PGAPPNAME environment variable)?

Could You support that?

My usage case: MS Access Linked Tables

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 26 Sep 2025 14:18:51 +0000

PR's are welcome.

---

From: "fjf2002 (@fjf2002)" <[email-masked]>
Date: Mon, 29 Sep 2025 06:35:34 +0000

@davecramer thanks for your reply. However I found out setting the app name is already supported. Add to the connection string

```
pqopt={application_name=foo}
```

May I hint as far as I understand "PR's" shall be plural, not genitive, therefore no apostrophe?

Closing ticket.