Subject: [postgresql-interfaces/psqlodbc] issue #140: Connection string: escape space

From: "fjf2002 (@fjf2002)" <[email-masked]>
Date: Wed, 22 Oct 2025 12:25:19 +0000

I had a connection string containing a libpq parameter value containing a space. But space is the separator for multiple values, so what to do?
I guessed a backslash is the escape symbol, and it worked.

Is that documented somewhere / you should document that at https://odbc.postgresql.org/docs/config.html ?

Thank You.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 24 Oct 2025 05:41:34 +0000

Please send in a PR with the documentation. 

Dave

---

From: "fjf2002 (@fjf2002)" <[email-masked]>
Date: Fri, 24 Oct 2025 11:13:40 +0000

Hello @davecramer, thank you for your reply.
However I just have guessed ONE THING and do not see the full picture.
- Are there other escape sequences?
- Does this work only in the libpq parameter or generally in the connection string?
- ...?

Can somebody help?