Subject: [postgresql-interfaces/psqlodbc] issue #141: failing tests - misconfiguration debugging

From: "OldManYellsAtCloud (@OldManYellsAtCloud)" <[email-masked]>
Date: Thu, 23 Oct 2025 14:23:35 +0000

This is not a bug (I think), I'm looking for a bit of tech support.

I'm using postgresql 17.6 along with psqlodbc 17.00.0006, using Yocto. I try to execute the testsuite - I managed to run most, but two tests (lfconversion and result-conversions) fail, and I'm a bit lost. Not sure where to start debugging it.

Both tests complain about "Received an unsupported type from Postgres"

<details>
<summary>lfconversion logs</summary>

```
connected
reading to char buffer...
strlen 22, SQLGetData claims 22

reading to char buffer, with truncation...
strlen 9, SQLGetData claims 22

reading to SQLWCHAR buffer...
SQLGetData failed
07006=Received an unsupported type from Postgres.
```

</details>

<details>
<summary>result-conversions logs</summary>

```

connected
Executed: SET intervalstyle=postgres
Executed: SET bytea_output=escape
Executed: SET lc_monetary='C'
'true' (boolean) as SQL_C_CHAR: 1
'true' (boolean) as SQL_C_WCHAR: SQLGetData failed
07006=Received an unsupported type from Postgres.
'true' (boolean) as SQL_C_SSHORT: 1
'true' (boolean) as SQL_C_USHORT: 1
'true' (boolean) as SQL_C_SLONG: 1
'true' (boolean) as SQL_C_ULONG: 1
'true' (boolean) as SQL_C_FLOAT: 1.000000

<... had to truncate because of github size limits, but can upload the full logs upon request...>

'' (text) as SQL_C_TYPE_TIMESTAMP: y: 0 m: 0 d: 0 h: 0 m: 0 s: 0 f: 0
'foobar' (text) as SQL_C_CHAR: foob (truncated)
'foobar' (text) as SQL_C_CHAR: fooba (truncated)
'foobar' (text) as SQL_C_CHAR: foobar
'foobar' (text) as SQL_C_WCHAR: SQLGetData failed
07006=Received an unsupported type from Postgres.
'foobar' (text) as SQL_C_WCHAR: SQLGetData failed
07006=Received an unsupported type from Postgres.
'foobar' (text) as SQL_C_WCHAR: SQLGetData failed
07006=Received an unsupported type from Postgres.
'foobar' (text) as SQL_C_WCHAR: SQLGetData failed
07006=Received an unsupported type from Postgres.
'foobar' (text) as SQL_C_WCHAR: SQLGetData failed
07006=Received an unsupported type from Postgres.
'' (text) as SQL_C_CHAR: 
'' (text) as SQL_C_WCHAR: SQLGetData failed
07006=Received an unsupported type from Postgres.
'2011-02-15 15:49:18' (timestamp) as SQL_C_CHAR: 2011-02-15 15:49:1 (truncated)
'2011-02-15 15:49:18 BC' (timestamp) as SQL_C_CHAR: 2011-02-15 15:49:18 (truncated)
'NaN' (float4) as SQL_C_FLOAT: nan
'Infinity' (float4) as SQL_C_FLOAT: inf
'-Infinity' (float4) as SQL_C_FLOAT: -inf
'NaN' (float8) as SQL_C_FLOAT: nan
'Infinity' (float8) as SQL_C_FLOAT: inf
'-Infinity' (float8) as SQL_C_FLOAT: -inf
'NaN' (float4) as SQL_C_DOUBLE: nan
'Infinity' (float4) as SQL_C_DOUBLE: inf
'-Infinity' (float4) as SQL_C_DOUBLE: -inf
'NaN' (float8) as SQL_C_DOUBLE: nan
'Infinity' (float8) as SQL_C_DOUBLE: inf
'-Infinity' (float8) as SQL_C_DOUBLE: -inf
disconnecting

```

</details>

I guess I have some wrong configuration somewhere or missing/wrong environment variable, but I'm not really sure where to start looking, what should I try. Could someone please give some pointers?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 03 Nov 2025 13:07:34 +0000

so are you using Yocto to build postgres, psqlodbc ?

It passes fine on my macos using standard tools

---

From: "OldManYellsAtCloud (@OldManYellsAtCloud)" <[email-masked]>
Date: Mon, 03 Nov 2025 14:03:19 +0000

Yes, both of them are built with Yocto. I do not believe that this is an issue with the tests, with psqlodbc nor with postgres - rather some mismatched config between the two that is currently beyond me