Subject: [postgresql-interfaces/psqlodbc] issue #142: `VCRUNTIME140_1.dll` lacks from `psqlodbc_x64.msi`

From: "kenjiuno (@kenjiuno)" <[email-masked]>
Date: Sun, 16 Nov 2025 11:35:50 +0000

I'm not sure whether this could be a problem or not.

I have installed `psqlodbc_x64.msi` of `REL-17_00_0006`.
I have checked the dependencies (with [Dependencies](https://github.com/lucasg/Dependencies)) of installed DLLs for a certain reason.

Only `pgxalib.dll` has a link to `VCRUNTIME140_1.dll`, which is not bundled in the psqlodbc folder. (While `vcruntime140.dll` is present)

<img width="942" height="555" alt="Image" src="https://github.com/user-attachments/assets/141355e3-53eb-48ec-ab9b-518e3d85c2c8" />

<img width="827" height="620" alt="Image" src="https://github.com/user-attachments/assets/34145a68-3c5c-4eb9-af53-69f97f053761" />

I almost use psqlodbc with a Visual Studio 2022-enabled environment, so this won't be a problem for me.

The workaround is to install the Latest supported redistributable version downloadable from the MSFT site: https://learn.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170#latest-supported-redistributable-version

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 17 Nov 2025 10:36:18 +0000

So do you think we need to bundle this or just document the requirement?

---

From: "kenjiuno (@kenjiuno)" <[email-masked]>
Date: Mon, 17 Nov 2025 12:58:17 +0000

> So do you think we need to bundle this or just document the requirement?

I apologize that I have no clear idea about how to deal with this issue.

I have looked at the installer build script.

https://github.com/postgresql-interfaces/psqlodbc/blob/main/installer/buildInstallers.ps1#L196

I could understand that this part has a potential issue. However, I cannot imagine how this can be fixed in my mind. The script is too hard for me to understand.

So my thought remains to just inform about this issue here.