Subject: [postgresql-interfaces/psqlodbc] issue #154: Workflow error: Install Win32OpenSSL fails

From: "fdcastel (@fdcastel)" <[email-masked]>
Date: Thu, 12 Feb 2026 05:04:12 +0000

I'm working on a PR for #153, but I’m having trouble reproducing the build process.

I only changed [`main.yml`](https://github.com/postgresql-interfaces/psqlodbc/blob/main/.github/workflows/main.yml) to run on pushes from any branch:

```yaml
on:
  push:
    branches: [ "*" ]
  pull_request:
    branches: [ "*" ]
``` 

But it is failing with

<img width="902" height="441" alt="Image" src="https://github.com/user-attachments/assets/94723c60-ce5a-4c56-b227-c6d6221fb48a" />

Also, do we really need to build PostgreSQL from source just to test the ODBC driver? Couldn’t we use the latest stable installer or prebuilt artifacts instead?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 12 Feb 2026 11:04:01 +0000

You don't need to build it from source. 
In order to fix the above problem, it is the version. They update this pretty regularly.

currently 3.3.6 https://slproweb.com/products/Win32OpenSSL.html

---

From: "fdcastel (@fdcastel)" <[email-masked]>
Date: Thu, 12 Feb 2026 15:03:54 +0000

Thank you, @davecramer!

Updating `OPENSSL_VERSION` to `3_3_6` indeed did the trick! The workflow is now moving forward _(building postgres now)_. 👍🏻 

That said, I’m still a bit puzzled, though. I went through the (failed) logs and couldn’t spot the actual reason it was failing. It looks like the download _completed_ successfully: 

<img width="694" height="1185" alt="Image" src="https://github.com/user-attachments/assets/a1e4e8b5-c361-428c-b93b-244d3e728cc9" />

So **why did the install step fail?**

Is there another place where 3_3_5 / 3_3_6 is being referenced that I’m missing?

Mostly asking because it might be worth improving the error message and saving the next “noob” from running into the same thing the next time the OpenSSL version bumps again 😄

---

From: "fdcastel (@fdcastel)" <[email-masked]>
Date: Thu, 12 Feb 2026 15:13:25 +0000

Oh man… the build is _still_ running. 😅

I suppose this is probably only on the first run because of the GitHub cache -- but still…

**Would you be open to a PR to modernize the current workflow?**

Possible improvements:
- install PostgreSQL from a pinned release (instead of building from source), and
- run x86 and x64 test jobs in parallel

_Of course, I'm a complete newbie, so I might be missing something 😄 -- If there are solid reasons for keeping it as-is, I totally understand._

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 05 Mar 2026 11:46:03 +0000

Oh, wow, I didn't see your response.

Yes, I would be up to a PR to mondernize the workflow