Subject: [postgresql-interfaces/psqlodbc] issue #158: Request: New MSI release with updated OpenSSL (fix for CVE‑2025‑15467)

From: "cbourner (@cbourner)" <[email-masked]>
Date: Mon, 09 Mar 2026 23:56:07 +0000

Hello maintainers,

Could you please publish a new psqlODBC Windows build (MSI) that includes an updated OpenSSL version?

The current latest release 7.00.0007 (Nov 2025) uses an OpenSSL which is vulnerable to CVE-2025-15467.

This vulnerability has been fixed in OpenSSL versions 3.3.6 / 3.4.4 / 3.5.5 / 3.6.1 / 3.0.19.

We are using psqlODBC in production (via SQL Server Reporting Services), and the bundled OpenSSL version is now affected by the above CVE.  A new MSI release would allow me to deploy a patched driver without building from source.

Thank you — happy to help test if needed.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Tue, 10 Mar 2026 10:07:15 +0000

sure, will try to get that released today

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Tue, 10 Mar 2026 20:30:27 +0000

released

---

From: "cbourner (@cbourner)" <[email-masked]>
Date: Wed, 11 Mar 2026 00:31:17 +0000

Many thanks - I didn't expect this to happen so quickly!

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Wed, 11 Mar 2026 13:41:51 +0000

With Github doing the release it's rather trivial as all I have to do is push a tag