Subject: [postgresql-interfaces/psqlodbc] issue #160: PG 19: ERROR: non-standard string literals are not supported

From: "df7cb (@df7cb)" <[email-masked]>
Date: Wed, 11 Mar 2026 10:11:38 +0000

The psqlodbc regression tests will need adjustments for the next PG major release:

```
+++ results/quotes.out	2026-03-11 10:53:56.127333862 +0100
 SET standard_conforming_strings=off
-Executing: SELECT 'foo', ?::text with param: param'quote
...
-disconnecting
+SQLExecDirect failed
+0A000=ERROR: non-standard string literals are not supported;
+Error while executing the query
```

```
2026-03-11 10:53:56.132 CET [581317] myon@contrib_regression ERROR:  non-standard string literals are not supported
2026-03-11 10:53:56.132 CET [581317] myon@contrib_regression STATEMENT:  SET standard_conforming_strings=off
```

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 12 Mar 2026 10:15:29 +0000

@df7cb thanks, I know I did that for pgjdbc, not sure why I forgot about psqlodbc

---

From: "df7cb (@df7cb)" <[email-masked]>
Date: Thu, 12 Mar 2026 10:19:33 +0000

Maybe because the JDBC interface is from this century. 😅

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Tue, 17 Mar 2026 09:43:33 +0000

I just merged in a patch that should help. It does require you changing the way you call installcheck  `make installcheck server_version=19  `