Subject: [postgresql-interfaces/psqlodbc] issue #168: OpenSSL EOL in Windows builds → request for 3.5 LTS adoption (compliance impact)

From: "crea-bank (@crea-bank)" <[email-masked]>
Date: Tue, 31 Mar 2026 11:58:56 +0000

Current Windows builds of psqlODBC appear to ship with OpenSSL 3.3.x, which reaches end of life in April 2026.

This causes issues in enterprise environments:

Security scanners flag the bundled OpenSSL as EOL / unsupported
Leads to audit findings (e.g. ISO 27001, internal policies)
Can become a deployment blocker

Upgrading to short-lived versions (e.g. 3.4.x) would only be a temporary fix.

Since OpenSSL 3.5 is now the LTS release (supported until 2030), it would be preferable to move directly to 3.5 in Windows builds.

Questions:

Are there plans to adopt OpenSSL 3.5 LTS?
Is there an expected timeline?

Thanks for your work on psqlODBC!

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Wed, 01 Apr 2026 09:23:56 +0000

Makes sense. Any chance you can provide a PR?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 02 Apr 2026 19:55:00 +0000

fixed with #169