Subject: [postgresql-interfaces/psqlodbc] issue #170: Included columns are included in SQLPrimaryKey() output

From: "oneeyeman1 (@oneeyeman1)" <[email-masked]>
Date: Fri, 03 Apr 2026 01:05:07 +0000

Description:

The title says it all.

Steps to reproduce:

1. Execute the following::

CREATE TABLE leagues_new(id serial, name varchar(100), drafttype smallint, scoringtype smallint, roundvalues smallint,leaguetype char(5), salary integer, benchplayers smallint, primary key(id) INCLUDE (drafttype, scoringtype) WITH( fillfactor = 50,deduplicate_items = OFF ));

2 Create a program using ODBC and call SQLPrimaryKey()
3 Observe that the result set will contain 3 records.

Observed vs expected behavior:

I was expecting to have only PK fields to be returned. But the included fields was also returned.

---

From: "oneeyeman1 (@oneeyeman1)" <[email-masked]>
Date: Tue, 21 Apr 2026 05:30:58 +0000

@davecramer ,
Thx.