Subject: [postgresql-interfaces/psqlodbc] issue #180: Incorrectly reported DB version

From: "Blacksmoke16 (@Blacksmoke16)" <[email-masked]>
Date: Sun, 03 May 2026 14:30:13 +0000

I noticed when using a Postgres version >= 10, the reported version from `SQL_DBMS_VER` is incorrect. E.g. the latest PG version `18.3` is reported at `18.0.3` instead of `18.3.0`

Probably related to the [versioning](https://www.postgresql.org/support/versioning/) changes in PG 10:

<img width="1848" height="142" alt="Image" src="https://github.com/user-attachments/assets/5dc80e9b-2679-49b3-b8eb-8de421c0d7b4" />

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Tue, 05 May 2026 10:29:44 +0000

Interesting, thanks for the report.

---

From: "Blacksmoke16 (@Blacksmoke16)" <[email-masked]>
Date: Thu, 07 May 2026 19:00:38 +0000

Fixed by #181