Subject: [postgresql-interfaces/psqlodbc] PR #25: Fixed bugs, reported in issue #8.

From: "progmachine (@progmachine)" <[email-masked]>
Date: Thu, 23 May 2024 16:08:37 +0000

Bunch of memory leaks, occuring in tests.
One heap-buffer-overrun in read operation at convert.c:3162.
Two memory leaks, detected by my unit tests:
  password, conn_settings, pqopt fields overwrite if their values provided by both, system config and connstring.
  Restored reference counting lifetime management of COL_INFO objects.
Some minor cosmetic changes.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 23 May 2024 19:35:57 +0000

(on connection.c)

Could you put comments on their own line. This is how the rest of the code is commented.

---

From: "progmachine (@progmachine)" <[email-masked]>
Date: Thu, 23 May 2024 21:14:58 +0000

(on connection.c)

Done.