Subject: [postgresql-interfaces/psqlodbc] issue #46: Support for Azure Managed Identity access token when connecting to Azure PostgreSQL

From: "acerock (@acerock)" <[email-masked]>
Date: Tue, 24 Sep 2024 10:49:46 +0000

Hi, are there any plans to support connect to Azure PostgreSQL using Entra identity access token, similar to [MSSQL ODBC](https://learn.microsoft.com/en-us/sql/connect/odbc/using-azure-active-directory?view=sql-server-ver16#authenticating-with-an-access-token)?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Wed, 25 Sep 2024 11:49:45 +0000

Currently we have no plans to implement this. Perhaps you might reach out to Microsoft to see if they want to implement it.

---

From: "duysqubix (@duysqubix)" <[email-masked]>
Date: Fri, 25 Jul 2025 16:08:13 +0000

Bump on this. Change of heart on this topic? Are there any alternatives that anyone is aware of? 3rd party postgres ODBC drivers?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 31 Jul 2025 22:34:12 +0000

I think it's worth doing. I'd have to spend some time on this. It would also have to work for all of the IDP providers