Subject: [postgresql-interfaces/psqlodbc] PR #48: Fix for issue #47 - double free of COL_INFO object

From: "progmachine (@progmachine)" <[email-masked]>
Date: Thu, 26 Sep 2024 11:40:59 +0000

* Fix for issue #47 - double free of COL_INFO object due to refcount breakage during reuse of directly found object in getColumnsInfo(...).
* One more possible memory leak of COL_INFO objects in getColumnsInfo(...).

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 26 Sep 2024 14:56:21 +0000

(on parse.c)

spelling mistake "refernce"  in comment

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 26 Sep 2024 23:38:10 +0000

@progmachine Thankyou

---

From: "progmachine (@progmachine)" <[email-masked]>
Date: Fri, 27 Sep 2024 09:38:09 +0000

How do you think, do we need to make the 16.0.6 bugfix release?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 27 Sep 2024 10:23:17 +0000

Yes, I am going to release 16.0.6 and then fast follow with 17 today