Subject: [postgresql-interfaces/psqlodbc] PR #66: Use WiX 5

From: "chrullrich (@chrullrich)" <[email-masked]>
Date: Fri, 11 Oct 2024 20:29:08 +0000

This branches from my other MSI branch. x64 and x86 build and work.

See the README for how to install what bits of WiX are needed.

WiX 5 does not use the file name in the key of the File table by default; I have changed modify_msi.vbs to identify its target files by the component ID instead ... and most recently by the file name itself.

---

From: "chrullrich (@chrullrich)" <[email-masked]>
Date: Sat, 12 Oct 2024 13:16:24 +0000

I don't think there is more that needs to be done here this side of adding the arm64 package.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 14 Oct 2024 09:41:57 +0000

I just have to now figure out why it fails

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 14 Oct 2024 09:42:10 +0000

Thanks so much for this!

---

From: "chrullrich (@chrullrich)" <[email-masked]>
Date: Mon, 14 Oct 2024 09:54:46 +0000

> I just have to now figure out why it fails

I saw that. Have another commit.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 14 Oct 2024 14:05:07 +0000

cool, thanks so much