Subject: [postgresql-interfaces/psqlodbc] PR #69: Correct wrong string method calls

From: "chrullrich (@chrullrich)" <[email-masked]>
Date: Wed, 23 Oct 2024 20:12:57 +0000

These two calls have no effect because `std::string::empty()` only tests for emptiness, but does not cause it as apparently intended.

---

From: "chrullrich (@chrullrich)" <[email-masked]>
Date: Wed, 23 Oct 2024 20:20:55 +0000

There is a chance that I'm misunderstanding the interaction between this code and `xa_recover()`, but I don't think so. The `AuthenticationError()` that `xa_recover()` tests for early on looks to be one coming from the `SQLDriverConnect()` just after these two lines.