Subject: [postgresql-interfaces/psqlodbc] issue #71: Configure script missing in psqlODBC version 17

From: "raddakal (@raddakal)" <[email-masked]>
Date: Mon, 18 Nov 2024 03:35:24 +0000

Hello All,

We are trying to compile and build psqlODBC version 17 ODBC driver for Linux 64 bit platform (OEL8 and OEL9 to be more specific) from source code.

We understand that the steps to compile and build are available at:
https://odbc.postgresql.org/docs/unix-compilation.html

To install, just try something like:

Step 1) % tar -zxvf psqlodbc-xx.xx.xxxx.tar.gz
Step 2) % cd psqlodbc-xx.xx.xxxx
Step 3) % ./configure
Step 4) % make
Step 5) % make install

When I downloaded the source code (REL-17_00_0002 Latest on Oct 2 ) from https://github.com/postgresql-interfaces/psqlodbc, I do not find the configure script in the downloaded package.

It is critical for us to build the driver from the source code and use (and not use any readily available binaries of the driver).

This is blocking one of our critical releases.

Can someone please suggest on the following:
As the configure script is missing from the driver source code package, is there any alternative way to compile and build the driver form source code.

A quick response is highly appreciated!!

Thanks,
Ranjeeth.

---

From: "raddakal (@raddakal)" <[email-masked]>
Date: Tue, 19 Nov 2024 13:27:41 +0000

We had to run the below mentioned command to generate the required configure script:
autoreconf -i

After doing this, was able to compile the source code and build the driver.

Thanks.