Subject: [postgresql-interfaces/psqlodbc] issue #72: Error at installing msi when it is added to a WIX bundle (in a chain)

From: "ScherzerThomas (@ScherzerThomas)" <[email-masked]>
Date: Mon, 18 Nov 2024 13:51:51 +0000

- Create a wix bundle containing the psqlodbc_x86.msi
```
<!-- Install database driver -->
<MsiPackage Id="psqlodbc_x86"
			SourceFile="psqlodbc_x86.msi"
			Permanent="yes" 
			Vital="yes" 
			Visible="yes">
</MsiPackage>
```
- Run the resulting exe
- Following error appears at installing:
![image](https://github.com/user-attachments/assets/af035bab-cde7-43c4-bbac-1bc441c91c8b)
```
Command Line: MSIFASTINSTALL=7 BURNMSIINSTALL=1 REINSTALLMODE=muso REBOOT=ReallySuppress CURRENTDIRECTORY=C:\tmp CLIENTUILEVEL=3 MSICLIENTUSESEXTERNALUI=1 CLIENTPROCESSID=348
```

[install.log](https://github.com/user-attachments/files/17801156/install.log)

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 18 Nov 2024 22:34:02 +0000

Which version are you trying to install ?

---

From: "ScherzerThomas (@ScherzerThomas)" <[email-masked]>
Date: Sat, 23 Nov 2024 05:56:48 +0000

> Which version are you trying to install ?

It's at all currently released v17 versions (mimalloc or without)

---

From: "chrullrich (@chrullrich)" <[email-masked]>
Date: Sun, 24 Nov 2024 11:19:25 +0000

I don't think this will happen with a post-#66 release, but there isn't one yet.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 25 Nov 2024 10:10:28 +0000

ah, ok, let me release one then