Subject: [postgresql-interfaces/psqlodbc] issue #74: encryption of password

From: "benjaminpochat (@benjaminpochat)" <[email-masked]>
Date: Thu, 21 Nov 2024 07:27:20 +0000

When you click SAVE the password is stored as clear text in
HKEY_CURRENT_USER\Software\ODBC\ODBC.INI\postgres\Password

Would it be possible to store the password encrypted ?

In my company, the use of postgre odbc client is compromised because
passwords are stored as clear text in Windows registry.
Our use case consists in individual authentication to postgre databases,
thanks to ldap2pg tool, for BI purposes.
As a consequence, individual passwords are used in odbc clients.
Then, the fact that postgre odbc client stores these personnal passwords as clear
text is a real security issue.

PS. : This issue follows [this discussion on psql-odbc mailing list ](https://www.postgresql.org/message-id/CADK3HHJqiZWkftjjD%3De_w3XLY6ri-0nXFKR4JQfL_dhab%2B8mig%40mail.gmail.com)

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 21 Nov 2024 10:15:24 +0000

Don't see why not. Someone will have to write the code though. PR's are welcome