Subject: [postgresql-interfaces/psqlodbc] PR #76: Install the drivers with short file names

From: "chrullrich (@chrullrich)" <[email-masked]>
Date: Sun, 24 Nov 2024 11:15:19 +0000

**This should be considered a backwards-incompatible change.**

I would really like some more eyes on this because I'm not at all sure it will actually work in reality, given that there may be all kinds of setups that do not go through the ODBC driver manager for opening a data source, and there may be complications with loading two copies of the same driver from different files.

It avoids the need to post-process the MSI file to work around http://wixtoolset.org/issues/1422/ (installing ODBC drivers with long file names fails) by changing the file names to be short, and registering the drivers on the short names. For compatibility with existing configurations the short-named DLLs are also installed with their original long names.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 06 Dec 2024 11:26:24 +0000

@chrullrich well nobody is stepping up. I find the only way to get eyes on things is to release it. Thoughts ?

---

From: "chrullrich (@chrullrich)" <[email-masked]>
Date: Mon, 09 Dec 2024 11:58:03 +0000

For want of a better idea, yes, I have to agree.