Subject: [postgresql-interfaces/psqlodbc] issue #84: fe_sendauth: no password supplied error if Application data folder or pgpass.conf is not accessible

From: "kobruleht (@kobruleht)" <[email-masked]>
Date: Thu, 26 Dec 2024 13:56:38 +0000

If  application data folder in Windows is not accessible,

driver shows wrong error message:

fe_sendauth: no password supplied

To reproduce:

1. Type Windows+R
2. Enter %appdata%
Directory C:\Users\userid\AppData\Roaming opens

3. Navigate one folder up and in Roaming folder properties, remove access rights from Roaming folder.
Or create PostgreSql/pgpass.conf file and remove rights from it.

5. Use odbc driver to log in with user which requires password and enter password.

Observed:

fe_sendauth: no password supplied

error appears and logging to server fails.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 30 Dec 2024 10:50:35 +0000

So is the problem that the error message is wrong or you can't login ?

---

From: "kobruleht (@kobruleht)" <[email-masked]>
Date: Mon, 30 Dec 2024 10:59:49 +0000

Both: itr is not possible to log in if password is supplied and error message is also wrong.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 30 Dec 2024 11:28:32 +0000

Oh, so even if you supply the password it doesn't work. Your message was a bit confusing.

---

From: "kobruleht (@kobruleht)" <[email-masked]>
Date: Mon, 30 Dec 2024 11:33:51 +0000

If correct password is supplied message is no password supplied.