Subject: [postgresql-interfaces/psqlodbc] issue #90: Unhandled exception on next query after network connection is disconnected then re-connected.

From: "tazervas (@tazervas)" <[email-masked]>
Date: Fri, 14 Feb 2025 13:58:51 +0000

If the network connection is lost and then re-connected during an ODBC session using version 17.00.0004 the next query will throw an "Attempted to read or write protected memory" exception which cannot be caught.  Version 16.00.00 throws exception "The connection has been disabled (or lost).  ERROR [08S01] server closed the connection unexpectedly" which can be caught and acted upon which is the desired behavior.

Example Visual Studio 2022 .NET 8 Windows Forms Visual Basic code which demonstrates this issue:

        Try

            Dim cs As New Odbc.OdbcConnectionStringBuilder
            cs.Clear()
            cs.Driver = "PostgreSQL Unicode(x64)"
            cs.Add("Database", "database")
            cs.Add("Servername", "host")
            cs.Add("UID", "user")
            cs.Add("PWD", "password")

            Dim c As Odbc.OdbcConnection = New Odbc.OdbcConnection With {.ConnectionString = cs.ConnectionString}
            c.Open()

            Dim sql As Odbc.OdbcCommand = c.CreateCommand
            sql.CommandType = CommandType.Text
            sql.CommandText = "SELECT count(*) FROM anytable"

            sql.ExecuteScalar()

            MsgBox("psqlODBC exception test: disconnect then re-connect network")

            sql.ExecuteScalar()     ' unhandled exception here

        Catch ex As Exception
            MsgBox(ex.ToString)

        End Try

Exception text:

System.AccessViolationException
  HResult=0x80004003
  Message=Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
  Source=<Cannot evaluate the exception source>
  StackTrace:
<Cannot evaluate the exception stack trace>

 	[Managed to Native Transition]	
 	System.Data.Odbc.dll!System.Data.Odbc.OdbcConnectionHandle.ReleaseHandle()	Unknown
 	System.Private.CoreLib.dll!System.Runtime.InteropServices.SafeHandle.InternalRelease(bool disposeOrFinalizeOperation)	Unknown
 	System.Private.CoreLib.dll!System.Runtime.InteropServices.SafeHandle.Dispose()	Unknown
 	System.Data.Odbc.dll!System.Data.Odbc.OdbcConnection.Close()	Unknown
 	System.Data.Odbc.dll!System.Data.Odbc.OdbcConnection.ConnectionIsAlive(System.Exception innerException)	Unknown
 	System.Data.Odbc.dll!System.Data.Odbc.OdbcConnection.HandleErrorNoThrow(System.Data.Odbc.OdbcHandle hrHandle, System.Data.Odbc.ODBC32.SQLRETURN retcode)	Unknown
 	System.Data.Odbc.dll!System.Data.Odbc.OdbcConnection.HandleError(System.Data.Odbc.OdbcHandle hrHandle, System.Data.Odbc.ODBC32.SQLRETURN retcode)	Unknown
 	System.Data.Odbc.dll!System.Data.Odbc.OdbcCommand.ExecuteReaderObject(System.Data.CommandBehavior behavior, string method, bool needReader, object[] methodArguments, System.Data.Odbc.ODBC32.SQL_API odbcApiMethod)	Unknown
 	System.Data.Odbc.dll!System.Data.Odbc.OdbcCommand.ExecuteReaderObject(System.Data.CommandBehavior behavior, string method, bool needReader)	Unknown
 	System.Data.Odbc.dll!System.Data.Odbc.OdbcCommand.ExecuteScalar()	Unknown
>	psqlodbc_17_0004_exception.dll!psqlodbc_17_0004_exception.Form1.Form1_Load(Object sender, System.EventArgs e) Line 43	Basic

---

From: "tazervas (@tazervas)" <[email-masked]>
Date: Fri, 28 Feb 2025 19:51:37 +0000

Verified that 16.00.0006 also fails with same AccessViolationException.  Verified that 16.00.0005 does NOT fail with AccessViolationException instead throws "The connection has been disabled (or lost). ERROR [08S01] server closed the connection unexpectedly" as expected and desired.  Suspect that one of the changes within .0006 is involved however in reviewing them I did not see anything that was obviously wrong.

---

From: "harukat (@harukat)" <[email-masked]>
Date: Thu, 24 Apr 2025 05:02:55 +0000

If you had connection pooling enabled by the driver manager when this occurred, it may be the same phenomenon I encountered. 
I am proposing the following modifications to it.

https://github.com/postgresql-interfaces/psqlodbc/pull/113

---

From: "tazervas (@tazervas)" <[email-masked]>
Date: Mon, 28 Apr 2025 18:59:04 +0000

> If you had connection pooling enabled by the driver manager when this occurred, it may be the same phenomenon I encountered. I am proposing the following modifications to it.
> 
> [#113](https://github.com/postgresql-interfaces/psqlodbc/pull/113)

Confirmed.  I had connection pooling enabled.