Subject: License LPGL and commercialization

From: "Hunt, Brian C." <[email-masked]>
Date: Wed, 24 Feb 2021 15:24:56 +0000

I have recently been told by outside council (lawyers) that our organization is unable to use LGPL licensed packages in software we plan to sell.
We have already built a web app using Python + Django.

Ticket:
#461 (Support use of pypgsql instead of psycopg) - Django (djangoproject.com)<https://code.djangoproject.com/ticket/461>
Seems to suggest the purpose of the LGPL license is not to prevent the intended use we have in mind (selling the web app to be hosted locally at other organizations). Instead it is to prevent other from building off the drivers and then selling those drivers.

Is that the case? Is our intended purpose within the license constraints outlined? Can we receive written confirmation that our intended use won't come back to hurt us and we have permission? Or can we not use your package in this way? We will be compliant with whatever outcome is required. If we need to move away from Django (psycopg2) then we can do that if needed.

Brian Hunt
Data Scientist I, Advanced Analytics
OSF HealthCare System
1306 N. Berkeley Ave. | Peoria, IL | 61603
p 309-308-9657 | f 309-308-0530
www.osfhealthcare.org<http://www.osfhealthcare.org/>
Facebook<http://www.facebook.com/osfhealthcare> | Twitter<http://www.twitter.com/osfhealthcare> | YouTube<http://www.youtube.com/osfhealthcare>
"Serving with the Greatest Care and Love"

====================
The information in this message is confidential and may be legally privileged. Access to this message by anyone other than the addressee is not authorized. If you are not the intended recipient, or an agent of the intended recipient, any disclosure, copying, or distribution of the message or any action or omission taken by you in reliance on it, is prohibited and may be unlawful. If you have received this message in error, please contact the sender immediately and permanently delete the original e-mail, attachment(s), and any copies.
====================

---

From: Daniele Varrazzo <[email-masked]>
Date: Wed, 24 Feb 2021 16:57:22 +0100

On Wed, 24 Feb 2021 at 16:55, Hunt, Brian C.
> I have recently been told by outside council (lawyers) that our organization is unable to use LGPL licensed packages in software we plan to sell.

Your lawyer is wrong.

> Seems to suggest the purpose of the LGPL license is not to prevent the intended use we have in mind (selling the web app to be hosted locally at other organizations). Instead it is to prevent other…

Correct. You are not forbidden to use psycopg2 in a closed source program.

-- Daniele

---

From: John Abraham <[email-masked]>
Date: Wed, 24 Feb 2021 09:05:43 -0700

Yeah I'd tell the lawyers to read the LGPL more carefully.  Or maybe get new lawyers who are familiar with the topic. 

Here's a useful link in plain language, in case your lawyers are having trouble with legalese :) https://www.gnu.org/licenses/why-not-lgpl.html

-- 
John Abraham
HBA Specto Incorporated
[email-masked]
403-232-1060 (unattended during the pandemic)
403-383-8024 (personal cell phone)

> On Feb 24, 2021, at 8:57 AM, Daniele Varrazzo <[email-masked]> wrote:
>

---

From: Federico Di Gregorio <[email-masked]>
Date: Wed, 24 Feb 2021 17:13:38 +0100

On 24/02/21 16:24, Hunt, Brian C. wrote:
> I have recently been told by outside council (lawyers) that our 
> organization is unable to use LGPL licensed packages in software we plan 
> to sell.
> 
> #461 (Support use of pypgsql instead of psycopg) – Django 
> (djangoproject.com) <https://code.djangoproject.com/ticket/461>
> 
> Seems to suggest the purpose of the LGPL license is not to prevent the 
> intended use we have in mind (selling the web app to be hosted locally 
> at other organizations). Instead it is to prevent other from building 
> off the drivers and then selling those drivers.
> 
> Is that the case? Is our intended purpose within the license constraints 
> outlined? Can we receive written confirmation that our intended use 
> won’t come back to hurt us and we have permission? Or can we not use 
> your package in this way? We will be compliant with whatever outcome is 
> required. If we need to move away from Django (psycopg2) then we can do 
> that if needed.

Dear Brian,

you can use psycopg2 in a proprietary, closed-source application as long 
as you don't modify psycopg2 itself and allow your users to replace the 
current version of the psycopg2 module with a new one (this is usually 
not a problem, unless you want to pack everything in a single 
executable). There is the misconception that the LGPL will "contaminate" 
Python, then Django and from there your application but this is not the 
case: accessing psycopg2 API via Python from a proprietary module is 
perfectly fine - we don't consider it "linking".

federico