Subject: Proper way to keep count of statements executed within current transaction

From: "Podrigal, Aron" <[email-masked]>
Date: Fri, 24 May 2019 15:49:04 -0500

Hi

I've seen many libraries using psycopg2 wrapping execution of statements
and in case of connection failure, it reconnects and submits the query
again.
Doing so in every case can lead to unexpected results when the connection
was reset after the first statement within a transaction.

Consider the following:

BEGIN; -- or autocommit = False
SELECT balance FROM accounts WHERE id = 1 FOR UPDATE;

-- User code does some processing with the returned value.
-- At this point the the server was restarted and connection is closed
-- The users code submits
UPDATE  accounts SET balance = x WHERE id = 1;
-- The UPDATE query fails due to lost connection, so the library code which
wraps the statement  reconnects and submits the query again.

My question is, what is the correct way to detect whether any statements
were executed successfully prior to the connection being lost. And decide
whether it is safe to automatically reconnect and resubmit the query ?

-- 

-
Aron Podrigal

---

From: Christophe Pettus <[email-masked]>
Date: Fri, 24 May 2019 13:56:18 -0700

> On May 24, 2019, at 13:49, Podrigal, Aron <[email-masked]> wrote:
> 
> My question is, what is the correct way to detect whether any statements were executed successfully prior to the connection being lost.

You can't.  This is exactly why you have transactions: In the case of a lost connection, you can assume the transaction was aborted, and retry the transaction from the start.

--
-- Christophe Pettus
   [email-masked]