Subject: Psycopg2 and postgresql 12

From: Dale Arntson <[email-masked]>
Date: Tue, 1 Oct 2019 19:10:09 +0000

Hi all,

Can anyone give me an update on the plans for psycopg2 support for 
postgresql 12?

Thanks,

-dale

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 1 Oct 2019 13:02:15 -0700

> Can anyone give me an update on the plans for psycopg2 support for

Not sure what you are looking for specifically, but:

In [11]: psycopg2.__version__
Out[11]: '2.8.3 (dt dec pq3 ext lo64)'

In [13]: con = psycopg2.connect("dbname=postgres user=postgres 
host=localhost port=5435")

In [12]: con.server_version
Out[12]: 120000

In [14]: cur = con.cursor()

In [15]: cur.execute("select * from pg_class")

In [16]: rs = cur.fetchall()

In [17]: len(rs)
Out[17]: 395

-- 
Adrian Klaver
[email-masked]

---

From: Daniele Varrazzo <[email-masked]>
Date: Wed, 2 Oct 2019 11:05:11 +0100

> Can anyone give me an update on the plans for psycopg2 support for

it should just work

-- Daniele