agora inbox for pgsql-admin@postgresql.org  
help / color / mirror / Atom feed
From: Johannes Truschnigg <johannes@truschnigg.info>
To: Ron Johnson <ronljohnsonjr@gmail.com>
Cc: Pgsql-admin <pgsql-admin@lists.postgresql.org>
Subject: Re: Postgresql 9.5: Streaming Replication: Secondaries Fail To Start Post WAL Error
Date: Wed, 29 May 2024 07:18:53 +0200
Message-ID: <Zla6vTUkFFDWgi_G@vault.lan> (raw)
In-Reply-To: <CANzqJaCjb=bNSF7mrxFJ8DmCfqG2nTz_FHS8dTZjHpumcUe35Q@mail.gmail.com>
References: <CAPCvfWcm0JDC+q54MSW7N90PYvh+PefaP6SxfonbkGcUwpS1+g@mail.gmail.com>
	<ZlYmsG4NX7WjzFs-@vault.lan>
	<CAPCvfWdaymCYkLz-AseQLwGj8qh6pT1Kx73LoS-wkNNrukEX_Q@mail.gmail.com>
	<ZlYsaFDpLdR9SgAM@vault.lan>
	<CANzqJaCjb=bNSF7mrxFJ8DmCfqG2nTz_FHS8dTZjHpumcUe35Q@mail.gmail.com>

On Tue, May 28, 2024 at 05:24:56PM -0400, Ron Johnson wrote:
> On Tue, May 28, 2024 at 3:11 PM Johannes Truschnigg <
> >[...]
> > Yes, replication slots can interrupt your primary.
> >
> 
> Please define "interrupt".  Using a replication slot, I thought files would
> just accumulate in pg_wal while the replica is down (or the network is
> slow, or the replica can't keep up with the primary).
> 
> Disaster, of course, when that disk fills up, but that's always been the
> case.

And that is exactly the scenario I meant when I said "interrupt". If you use
replication slots, your monitoring/alerting isn't set up correctly, and you're
accumulating a lot of WAL, chances are ENOSPC on the primary is around the
corner for you.

That's why I generally prefer a WAL archive on a separate file system for
replicas to source segments from, because filling that up won't break the
primary (unless the archive_command misbehaves). That also needs proper
monitoring/alerting, of course (and a contingency plan for what to do when/if
the archive runs over) - but everyone whose workload is important enough for a
replication setup to make sense is required to have that in my book.

-- 
with best regards:
- Johannes Truschnigg ( johannes@truschnigg.info )

www:   https://johannes.truschnigg.info/

Attachments:

  [application/pgp-signature] signature.asc (832B, ../Zla6vTUkFFDWgi_G@vault.lan/2-signature.asc)
  download

view thread (8+ messages)  latest in thread

Message-ID: <Zla6vTUkFFDWgi_G@vault.lan>
Permalink:  ../Zla6vTUkFFDWgi_G@vault.lan/
Also on:    postgresql.org/message-id/Zla6vTUkFFDWgi_G@vault.lan

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-admin@postgresql.org
  Cc: johannes@truschnigg.info, ronljohnsonjr@gmail.com, pgsql-admin@lists.postgresql.org
  Subject: Re: Postgresql 9.5: Streaming Replication: Secondaries Fail To Start Post WAL Error
  In-Reply-To: <Zla6vTUkFFDWgi_G@vault.lan>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox