agora inbox for pgsql-admin@postgresql.org  
help / color / mirror / Atom feed
From: Dischner, Anton <Anton.Dischner@med.uni-muenchen.de>
To: Domen Šetar <domen.setar@izum.si>
Cc: pgsql-admin@lists.postgresql.org <pgsql-admin@lists.postgresql.org>
Subject: AW: wal seams to be corrupted
Date: Fri, 19 Jul 2024 07:15:31 +0000
Message-ID: <d700a9b981f84f8fb2b598fe8780a4e6@med.uni-muenchen.de> (raw)
In-Reply-To: <a3391a6f61cc492c98078c65c88c66fc@izum.si>
References: <a3391a6f61cc492c98078c65c88c66fc@izum.si>

Hi,

glad you found the problem. Had it in mind but didn’t dare to say it 😉

Maybe you want to install a monitor software like check_mk or Icinga. We use both and uptime_kuma to get noticed if services trend to fail or have failed.
BTW: check_mk and the  PostgreSQL is also a very nice tool.

Best regards,

Anton

Von: Domen Šetar <domen.setar@izum.si>
Gesendet: Freitag, 19. Juli 2024 09:08
An: pgsql-admin@lists.postgresql.org
Betreff: RE: wal seams to be corrupted

Thank you admins for helping me.
The problem was stupid and I'm a little bit ashamed.
Archive disk was full and I didn't notice it.
I made some space on it and everything is ok know.

Best regards!
[izum]

Domen Šetar
Computer Systems Support
IZUM – Institute of Information Science | Prešernova ulica 17 | 2000 Maribor | Slovenia
T: +386 2 25 20 339 | M: +386 41 676 342 | www.izum.si<http://www.izum.si/; | domen.setar@izum.si<mailto:domen.setar@izum.si>



From: Domen Šetar
Sent: Friday, July 19, 2024 7:58 AM
To: pgsql-admin@lists.postgresql.org<mailto:pgsql-admin@lists.postgresql.org>
Subject: wal seams to be corrupted

Hi admins,

The number of wal files on my postgresql server is rising, because it seams that one wal is corrupted. Postgrsql is running normaly.  I see this in postgresql log file:

2024-07-19 07:44:12 CEST [2205]: [32288-1] user=,db=,app=,client= DETAIL:  The failed archive command was: test ! -f /var/lib/pgsql/ArchiveDir/000000010000044E0000009D && cp pg_wal/000000010000044E0000009D /var/lib/pgsql/ArchiveDir/000000010000044E0000009D

Usualy helped if I deleted wal in ArchiveDir directory. But not this time. Wal is copied again from pg_wal to ArchiveDir directory and  error message continues.
What can I do to solve this problem? Is pg_resetwal solution fort his problem? If it is, how to use it?

Best regards!
[izum]

Domen Šetar
Computer Systems Support
IZUM – Institute of Information Science | Prešernova ulica 17 | 2000 Maribor | Slovenia
T: +386 2 25 20 339 | M: +386 41 676 342 | www.izum.si<http://www.izum.si/; | domen.setar@izum.si<mailto:domen.setar@izum.si>





Attachments:

  [image/jpeg] image001.jpg (1.3K, ../d700a9b981f84f8fb2b598fe8780a4e6@med.uni-muenchen.de/3-image001.jpg)
  download | view image

Message-ID: <d700a9b981f84f8fb2b598fe8780a4e6@med.uni-muenchen.de>
Permalink:  ../d700a9b981f84f8fb2b598fe8780a4e6@med.uni-muenchen.de/
Also on:    postgresql.org/message-id/d700a9b981f84f8fb2b598fe8780a4e6@med.uni-muenchen.de

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-admin@postgresql.org
  Cc: Anton.Dischner@med.uni-muenchen.de, domen.setar@izum.si, pgsql-admin@lists.postgresql.org
  Subject: Re: AW: wal seams to be corrupted
  In-Reply-To: <d700a9b981f84f8fb2b598fe8780a4e6@med.uni-muenchen.de>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox