pg.ddx.io  pgsql-committers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
pgsql: Rename (new|old)estCommitTs to (new|old)estCommitTsXid
2+ messages / 1 participants
[nested] [flat]

* pgsql: Rename (new|old)estCommitTs to (new|old)estCommitTsXid
@ 2015-12-28 20:35 Joe Conway <mail@joeconway.com>
  0 siblings, 0 replies; 2+ messages in thread

From: Joe Conway @ 2015-12-28 20:35 UTC (permalink / raw)
  To: pgsql-committers

Rename (new|old)estCommitTs to (new|old)estCommitTsXid

The variables newestCommitTs and oldestCommitTs sound as if they are
timestamps, but in fact they are the transaction Ids that correspond
to the newest and oldest timestamps rather than the actual timestamps.
Rename these variables to reflect that they are actually xids: to wit
newestCommitTsXid and oldestCommitTsXid respectively. Also modify
related code in a similar fashion, particularly the user facing output
emitted by pg_controldata and pg_resetxlog.

Complaint and patch by me, review by Tom Lane and Alvaro Herrera.
Backpatch to 9.5 where these variables were first introduced.

Branch
------
master

Details
-------
http://git.postgresql.org/pg/commitdiff/241448b23adf3432988f2b4012ff90a338b4d0bf

Modified Files
--------------
src/backend/access/rmgrdesc/xlogdesc.c  |    4 +--
src/backend/access/transam/commit_ts.c  |   52 +++++++++++++++----------------
src/backend/access/transam/xlog.c       |   16 +++++-----
src/backend/commands/vacuum.c           |    2 +-
src/bin/pg_controldata/pg_controldata.c |    8 ++---
src/bin/pg_resetxlog/pg_resetxlog.c     |   44 +++++++++++++-------------
src/include/access/commit_ts.h          |    2 +-
src/include/access/transam.h            |    4 +--
src/include/catalog/pg_control.h        |    4 +--
9 files changed, 68 insertions(+), 68 deletions(-)


-- 
Sent via pgsql-committers mailing list (pgsql-committers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-committers


^ permalink  raw  reply  [nested|flat] 2+ messages in thread

* pgsql: Rename (new|old)estCommitTs to (new|old)estCommitTsXid
@ 2015-12-28 20:35 Joe Conway <mail@joeconway.com>
  0 siblings, 0 replies; 2+ messages in thread

From: Joe Conway @ 2015-12-28 20:35 UTC (permalink / raw)
  To: pgsql-committers

Rename (new|old)estCommitTs to (new|old)estCommitTsXid

The variables newestCommitTs and oldestCommitTs sound as if they are
timestamps, but in fact they are the transaction Ids that correspond
to the newest and oldest timestamps rather than the actual timestamps.
Rename these variables to reflect that they are actually xids: to wit
newestCommitTsXid and oldestCommitTsXid respectively. Also modify
related code in a similar fashion, particularly the user facing output
emitted by pg_controldata and pg_resetxlog.

Complaint and patch by me, review by Tom Lane and Alvaro Herrera.
Backpatch to 9.5 where these variables were first introduced.

Branch
------
REL9_5_STABLE

Details
-------
http://git.postgresql.org/pg/commitdiff/282fdfcdc8a8f987c06e839d581b94bf196def8a

Modified Files
--------------
src/backend/access/rmgrdesc/xlogdesc.c  |    4 +--
src/backend/access/transam/commit_ts.c  |   52 +++++++++++++++----------------
src/backend/access/transam/xlog.c       |   16 +++++-----
src/backend/commands/vacuum.c           |    2 +-
src/bin/pg_controldata/pg_controldata.c |    8 ++---
src/bin/pg_resetxlog/pg_resetxlog.c     |   44 +++++++++++++-------------
src/include/access/commit_ts.h          |    2 +-
src/include/access/transam.h            |    4 +--
src/include/catalog/pg_control.h        |    4 +--
9 files changed, 68 insertions(+), 68 deletions(-)


-- 
Sent via pgsql-committers mailing list (pgsql-committers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-committers


^ permalink  raw  reply  [nested|flat] 2+ messages in thread


end of thread, other threads:[~2015-12-28 20:35 UTC | newest]

Thread overview: 2+ messages (download: mbox mbox.gz follow: Atom feed)
-- links below jump to the message on this page --
2015-12-28 20:35 pgsql: Rename (new|old)estCommitTs to (new|old)estCommitTsXid Joe Conway <mail@joeconway.com>
2015-12-28 20:35 pgsql: Rename (new|old)estCommitTs to (new|old)estCommitTsXid Joe Conway <mail@joeconway.com>

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox