pg.ddx.io  pgsql-committers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Joe Conway <mail@joeconway.com>
To: pgsql-committers@postgresql.org
Subject: pgsql: Rename (new|old)estCommitTs to (new|old)estCommitTsXid
Date: Mon, 28 Dec 2015 20:35:59 +0000
Message-ID: <E1aDeWN-000344-Kv@gemulon.postgresql.org> (raw)
List-Unsubscribe:  <mailto:majordomo@postgresql.org?body=unsub%20pgsql-committers>

Rename (new|old)estCommitTs to (new|old)estCommitTsXid

The variables newestCommitTs and oldestCommitTs sound as if they are
timestamps, but in fact they are the transaction Ids that correspond
to the newest and oldest timestamps rather than the actual timestamps.
Rename these variables to reflect that they are actually xids: to wit
newestCommitTsXid and oldestCommitTsXid respectively. Also modify
related code in a similar fashion, particularly the user facing output
emitted by pg_controldata and pg_resetxlog.

Complaint and patch by me, review by Tom Lane and Alvaro Herrera.
Backpatch to 9.5 where these variables were first introduced.

Branch
------
REL9_5_STABLE

Details
-------
http://git.postgresql.org/pg/commitdiff/282fdfcdc8a8f987c06e839d581b94bf196def8a

Modified Files
--------------
src/backend/access/rmgrdesc/xlogdesc.c  |    4 +--
src/backend/access/transam/commit_ts.c  |   52 +++++++++++++++----------------
src/backend/access/transam/xlog.c       |   16 +++++-----
src/backend/commands/vacuum.c           |    2 +-
src/bin/pg_controldata/pg_controldata.c |    8 ++---
src/bin/pg_resetxlog/pg_resetxlog.c     |   44 +++++++++++++-------------
src/include/access/commit_ts.h          |    2 +-
src/include/access/transam.h            |    4 +--
src/include/catalog/pg_control.h        |    4 +--
9 files changed, 68 insertions(+), 68 deletions(-)


-- 
Sent via pgsql-committers mailing list (pgsql-committers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-committers


view thread (2+ messages)

Message-ID: <E1aDeWN-000344-Kv@gemulon.postgresql.org>
Permalink:  ../E1aDeWN-000344-Kv@gemulon.postgresql.org/
Also on:    postgresql.org/message-id/E1aDeWN-000344-Kv@gemulon.postgresql.org

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-committers@postgresql.org
  Cc: mail@joeconway.com
  Subject: Re: pgsql: Rename (new|old)estCommitTs to (new|old)estCommitTsXid
  In-Reply-To: <E1aDeWN-000344-Kv@gemulon.postgresql.org>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox