pg.ddx.io  pgsql-committers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Nathan Bossart <nathan@postgresql.org>
To: pgsql-committers@lists.postgresql.org
Subject: pgsql: Rename CHECKPOINT_IMMEDIATE to CHECKPOINT_FAST.
Date: Fri, 11 Jul 2025 16:52:09 +0000
Message-ID: <E1uaGyn-005mrG-1j@gemulon.postgresql.org> (raw)

Rename CHECKPOINT_IMMEDIATE to CHECKPOINT_FAST.

The new name more accurately reflects the effects of this flag on a
requested checkpoint.  Checkpoint-related log messages (i.e., those
controlled by the log_checkpoints configuration parameter) will now
say "fast" instead of "immediate", too.  Likewise, references to
"immediate" checkpoints in the documentation have been updated to
say "fast".  This is preparatory work for a follow-up commit that
will add a MODE option to the CHECKPOINT command.

Author: Christoph Berg <myon@debian.org>
Discussion: https://postgr.es/m/aDnaKTEf-0dLiEfz%40msg.df7cb.de

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/bb938e2c3c7a955090f8b68b5bf75d064f6a36a0

Modified Files
--------------
doc/src/sgml/backup.sgml                         |  2 +-
doc/src/sgml/func.sgml                           |  2 +-
doc/src/sgml/ref/checkpoint.sgml                 |  2 +-
doc/src/sgml/ref/pg_basebackup.sgml              |  3 ++-
src/backend/access/transam/xlog.c                | 25 ++++++++++++------------
src/backend/commands/dbcommands.c                | 10 +++++-----
src/backend/commands/tablespace.c                |  2 +-
src/backend/postmaster/checkpointer.c            | 24 +++++++++++------------
src/backend/storage/buffer/bufmgr.c              |  4 ++--
src/backend/tcop/utility.c                       |  2 +-
src/include/access/xlog.h                        |  2 +-
src/test/recovery/t/041_checkpoint_at_promote.pl |  2 +-
12 files changed, 40 insertions(+), 40 deletions(-)



Message-ID: <E1uaGyn-005mrG-1j@gemulon.postgresql.org>
Permalink:  ../E1uaGyn-005mrG-1j@gemulon.postgresql.org/
Also on:    postgresql.org/message-id/E1uaGyn-005mrG-1j@gemulon.postgresql.org

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-committers@postgresql.org
  Cc: nathan@postgresql.org, pgsql-committers@lists.postgresql.org
  Subject: Re: pgsql: Rename CHECKPOINT_IMMEDIATE to CHECKPOINT_FAST.
  In-Reply-To: <E1uaGyn-005mrG-1j@gemulon.postgresql.org>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox