pg.ddx.io  pgsql-committers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Amit Kapila <akapila@postgresql.org>
To: pgsql-committers@lists.postgresql.org
Subject: pgsql: Rename column slotsync_skip_at to slotsync_last_skip.
Date: Fri, 05 Dec 2025 04:22:54 +0000
Message-ID: <E1vRNLJ-002sUg-2A@gemulon.postgresql.org> (raw)

Rename column slotsync_skip_at to slotsync_last_skip.

Commit 76b78721ca introduced two new columns in pg_stat_replication_slots
to improve monitoring of slot synchronization. One of these columns was
named slotsync_skip_at, which is inconsistent with the naming convention
used for similar columns in other system views.

Columns that store timestamps of the most recent event typically use the
'last_' in the column name (e.g., last_autovacuum, checksum_last_failure).
Renaming slotsync_skip_at to slotsync_last_skip aligns with this pattern,
making the purpose of the column clearer and improving overall consistency
across the views.

Author: Shlok Kyal <shlok.kyal.oss@gmail.com>
Reviewed-by: Michael Banck <mbanck@gmx.net>
Discussion: https://postgr.es/m/20251128091552.GB13635@p46.dedyn.io;lightning.p46.dedyn.io
Discussion: https://postgr.es/m/CAE9k0PkhfKrTEAsGz4DjOhEj1nQ+hbQVfvWUxNacD38ibW3a1g@mail.gmail.com

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/5db6a344abc2dfbc5df454cd93a096443ea4dd3e

Modified Files
--------------
contrib/test_decoding/expected/stats.out     | 12 ++++++------
doc/src/sgml/monitoring.sgml                 |  2 +-
src/backend/catalog/system_views.sql         |  2 +-
src/backend/utils/activity/pgstat_replslot.c |  2 +-
src/backend/utils/adt/pgstatfuncs.c          |  6 +++---
src/include/catalog/catversion.h             |  2 +-
src/include/catalog/pg_proc.dat              |  2 +-
src/include/pgstat.h                         |  2 +-
src/test/regress/expected/rules.out          |  4 ++--
9 files changed, 17 insertions(+), 17 deletions(-)



Message-ID: <E1vRNLJ-002sUg-2A@gemulon.postgresql.org>
Permalink:  ../E1vRNLJ-002sUg-2A@gemulon.postgresql.org/
Also on:    postgresql.org/message-id/E1vRNLJ-002sUg-2A@gemulon.postgresql.org

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-committers@postgresql.org
  Cc: akapila@postgresql.org, pgsql-committers@lists.postgresql.org
  Subject: Re: pgsql: Rename column slotsync_skip_at to slotsync_last_skip.
  In-Reply-To: <E1vRNLJ-002sUg-2A@gemulon.postgresql.org>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox