From: Nathan Bossart <nathan@postgresql.org>
To: pgsql-committers@lists.postgresql.org
Subject: pgsql: Rename pg_popcount_avx512.c to pg_popcount_x86.c.
Date: Wed, 21 Jan 2026 20:21:28 +0000
Message-ID: <E1viehj-001rTy-2R@gemulon.postgresql.org> (raw)
Rename pg_popcount_avx512.c to pg_popcount_x86.c.
This is preparatory work for a follow-up commit that will move the
rest of the x86-64-specific popcount code to this file.
Reviewed-by: John Naylor <johncnaylorls@gmail.com>
Discussion: https://postgr.es/m/aWf_InS1VrbeXAfP%40nathan
Branch
------
master
Details
-------
https://git.postgresql.org/pg/commitdiff/fbe327e5b465dff0fe5ce66ceff08ab9de9ef758
Modified Files
--------------
src/port/Makefile | 2 +-
src/port/meson.build | 2 +-
src/port/{pg_popcount_avx512.c => pg_popcount_x86.c} | 6 +++---
3 files changed, 5 insertions(+), 5 deletions(-)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-committers@postgresql.org
Cc: nathan@postgresql.org, pgsql-committers@lists.postgresql.org
Subject: Re: pgsql: Rename pg_popcount_avx512.c to pg_popcount_x86.c.
In-Reply-To: <E1viehj-001rTy-2R@gemulon.postgresql.org>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox