From: Peter Geoghegan <pg@bowt.ie>
To: pgsql-committers@lists.postgresql.org
Subject: pgsql: Rename heapam_index_fetch_tuple argument for clarity.
Date: Sat, 04 Apr 2026 15:30:31 +0000
Message-ID: <E1w92xC-002vaK-2W@gemulon.postgresql.org> (raw)
Rename heapam_index_fetch_tuple argument for clarity.
Rename heapam_index_fetch_tuple's call_again argument to heap_continue,
for consistency with the pointed-to variable name (IndexScanDescData's
xs_heap_continue field).
Preparation for an upcoming commit that will move index scan related
heapam functions into their own file.
Author: Peter Geoghegan <pg@bowt.ie>
Reviewed-By: Andres Freund <andres@anarazel.de>
Discussion: https://postgr.es/m/bmbrkiyjxoal6o5xadzv5bveoynrt3x37wqch7w3jnwumkq2yo@b4zmtnrfs4mh
Branch
------
master
Details
-------
https://git.postgresql.org/pg/commitdiff/1adff1a0c558ecaef4fbe4cf343c426a59414749
Modified Files
--------------
src/backend/access/heap/heapam_handler.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-committers@postgresql.org
Cc: pg@bowt.ie, pgsql-committers@lists.postgresql.org
Subject: Re: pgsql: Rename heapam_index_fetch_tuple argument for clarity.
In-Reply-To: <E1w92xC-002vaK-2W@gemulon.postgresql.org>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox