agora inbox for pgsql-committers@postgresql.org  
help / color / mirror / Atom feed
pgsql: Shorten pg_attribute_always_inline to pg_always_inline
7+ messages / 1 participants
[nested] [flat]

* pgsql: Shorten pg_attribute_always_inline to pg_always_inline
@ 2026-07-11 16:03  Tomas Vondra <tomas.vondra@postgresql.org>
  0 siblings, 0 replies; 7+ messages in thread

From: Tomas Vondra @ 2026-07-11 16:03 UTC (permalink / raw)
  To: pgsql-committers@lists.postgresql.org

Shorten pg_attribute_always_inline to pg_always_inline

The pg_attribute_always_inline macro name is so long it forces pgindent
to format the code in strange ways. Which may incentivize patch authors
to either structure the code in strange ways (e.g. reorder prototypes),
use shorter names, etc. Neither is very desirable for code readability.

This shortens the name by removing the _attribute_ part. It also makes
it more consistent with pg_noinline, which does not have the _attribute_
part either.

Backpatched to all supported branches, to prevent conflicts when
backpatching other fixes. The backbranches however keep both the old and
new macro name, so that existing code keeps working.

Author: Andres Freund <andres@anarazel.de>
Reviewed-by: Peter Geoghegan <pg@bowt.ie>
Reviewed-by: Tomas Vondra <tomas@vondra.me>
Discussion: https://postgr.es/m/bqqdehahpoa36igpictuqyn2s2mexk3t3ehidh2ffd2slb35e5@rzgksuiszgbg
Backpatch-through: 14

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/1c4b1de888559a47df599dcef356ea7fbf96fd0c

Modified Files
--------------
src/backend/access/heap/heapam.c      |  2 +-
src/backend/access/transam/xlog.c     |  4 +--
src/backend/commands/copyfromparse.c  | 32 ++++++++++-----------
src/backend/commands/copyto.c         |  4 +--
src/backend/executor/execExprInterp.c | 54 +++++++++++++++++------------------
src/backend/executor/execTuples.c     |  6 ++--
src/backend/executor/nodeHashjoin.c   |  2 +-
src/backend/executor/nodeSeqscan.c    |  4 +--
src/backend/nodes/queryjumblefuncs.c  |  6 ++--
src/backend/storage/buffer/bufmgr.c   | 24 ++++++++--------
src/backend/utils/adt/json.c          |  2 +-
src/backend/utils/cache/catcache.c    |  2 +-
src/include/c.h                       |  8 +++---
src/include/executor/execScan.h       | 18 ++++++------
src/include/portability/instr_time.h  |  8 +++---
15 files changed, 88 insertions(+), 88 deletions(-)



^ permalink  raw  reply  [nested|flat] 7+ messages in thread

* pgsql: Shorten pg_attribute_always_inline to pg_always_inline
@ 2026-07-11 16:03  Tomas Vondra <tomas.vondra@postgresql.org>
  0 siblings, 0 replies; 7+ messages in thread

From: Tomas Vondra @ 2026-07-11 16:03 UTC (permalink / raw)
  To: pgsql-committers@lists.postgresql.org

Shorten pg_attribute_always_inline to pg_always_inline

The pg_attribute_always_inline macro name is so long it forces pgindent
to format the code in strange ways. Which may incentivize patch authors
to either structure the code in strange ways (e.g. reorder prototypes),
use shorter names, etc. Neither is very desirable for code readability.

This shortens the name by removing the _attribute_ part. It also makes
it more consistent with pg_noinline, which does not have the _attribute_
part either.

Backpatched to all supported branches, to prevent conflicts when
backpatching other fixes. The backbranches however keep both the old and
new macro name, so that existing code keeps working.

Author: Andres Freund <andres@anarazel.de>
Reviewed-by: Peter Geoghegan <pg@bowt.ie>
Reviewed-by: Tomas Vondra <tomas@vondra.me>
Discussion: https://postgr.es/m/bqqdehahpoa36igpictuqyn2s2mexk3t3ehidh2ffd2slb35e5@rzgksuiszgbg
Backpatch-through: 14

Branch
------
REL_19_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/a474c01c87661f85827736dc8cfc353fd63c6ecf

Modified Files
--------------
src/backend/access/heap/heapam.c      |  2 +-
src/backend/access/transam/xlog.c     |  4 +--
src/backend/commands/copyfromparse.c  | 32 ++++++++++-----------
src/backend/commands/copyto.c         |  4 +--
src/backend/executor/execExprInterp.c | 54 +++++++++++++++++------------------
src/backend/executor/execTuples.c     |  6 ++--
src/backend/executor/nodeHashjoin.c   |  2 +-
src/backend/executor/nodeSeqscan.c    |  4 +--
src/backend/nodes/queryjumblefuncs.c  |  6 ++--
src/backend/storage/buffer/bufmgr.c   | 24 ++++++++--------
src/backend/utils/adt/json.c          |  2 +-
src/backend/utils/cache/catcache.c    |  2 +-
src/include/c.h                       |  9 +++++-
src/include/executor/execScan.h       | 18 ++++++------
src/include/portability/instr_time.h  |  8 +++---
15 files changed, 92 insertions(+), 85 deletions(-)



^ permalink  raw  reply  [nested|flat] 7+ messages in thread

* pgsql: Shorten pg_attribute_always_inline to pg_always_inline
@ 2026-07-11 16:04  Tomas Vondra <tomas.vondra@postgresql.org>
  0 siblings, 0 replies; 7+ messages in thread

From: Tomas Vondra @ 2026-07-11 16:04 UTC (permalink / raw)
  To: pgsql-committers@lists.postgresql.org

Shorten pg_attribute_always_inline to pg_always_inline

The pg_attribute_always_inline macro name is so long it forces pgindent
to format the code in strange ways. Which may incentivize patch authors
to either structure the code in strange ways (e.g. reorder prototypes),
use shorter names, etc. Neither is very desirable for code readability.

This shortens the name by removing the _attribute_ part. It also makes
it more consistent with pg_noinline, which does not have the _attribute_
part either.

Backpatched to all supported branches, to prevent conflicts when
backpatching other fixes. The backbranches however keep both the old and
new macro name, so that existing code keeps working.

Author: Andres Freund <andres@anarazel.de>
Reviewed-by: Peter Geoghegan <pg@bowt.ie>
Reviewed-by: Tomas Vondra <tomas@vondra.me>
Discussion: https://postgr.es/m/bqqdehahpoa36igpictuqyn2s2mexk3t3ehidh2ffd2slb35e5@rzgksuiszgbg
Backpatch-through: 14

Branch
------
REL_18_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/d1d9688b1f92590110cb868ce4f65f39da0af2a8

Modified Files
--------------
src/backend/access/heap/heapam.c      |  2 +-
src/backend/access/transam/xlog.c     |  4 +--
src/backend/commands/copyfromparse.c  | 26 ++++++++---------
src/backend/commands/copyto.c         |  4 +--
src/backend/executor/execExprInterp.c | 54 +++++++++++++++++------------------
src/backend/executor/execTuples.c     |  6 ++--
src/backend/executor/nodeHashjoin.c   |  2 +-
src/backend/nodes/queryjumblefuncs.c  |  6 ++--
src/backend/storage/buffer/bufmgr.c   | 14 ++++-----
src/backend/utils/adt/json.c          |  2 +-
src/backend/utils/cache/catcache.c    |  2 +-
src/include/c.h                       |  9 +++++-
src/include/executor/execScan.h       | 18 ++++++------
13 files changed, 78 insertions(+), 71 deletions(-)



^ permalink  raw  reply  [nested|flat] 7+ messages in thread

* pgsql: Shorten pg_attribute_always_inline to pg_always_inline
@ 2026-07-11 16:04  Tomas Vondra <tomas.vondra@postgresql.org>
  0 siblings, 0 replies; 7+ messages in thread

From: Tomas Vondra @ 2026-07-11 16:04 UTC (permalink / raw)
  To: pgsql-committers@lists.postgresql.org

Shorten pg_attribute_always_inline to pg_always_inline

The pg_attribute_always_inline macro name is so long it forces pgindent
to format the code in strange ways. Which may incentivize patch authors
to either structure the code in strange ways (e.g. reorder prototypes),
use shorter names, etc. Neither is very desirable for code readability.

This shortens the name by removing the _attribute_ part. It also makes
it more consistent with pg_noinline, which does not have the _attribute_
part either.

Backpatched to all supported branches, to prevent conflicts when
backpatching other fixes. The backbranches however keep both the old and
new macro name, so that existing code keeps working.

Author: Andres Freund <andres@anarazel.de>
Reviewed-by: Peter Geoghegan <pg@bowt.ie>
Reviewed-by: Tomas Vondra <tomas@vondra.me>
Discussion: https://postgr.es/m/bqqdehahpoa36igpictuqyn2s2mexk3t3ehidh2ffd2slb35e5@rzgksuiszgbg
Backpatch-through: 14

Branch
------
REL_17_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/885dc83380999842fb568af292529ea089c93d89

Modified Files
--------------
src/backend/access/heap/heapam.c      |  2 +-
src/backend/access/transam/xlog.c     |  4 +--
src/backend/executor/execExprInterp.c | 50 +++++++++++++++++------------------
src/backend/executor/execTuples.c     |  6 ++---
src/backend/executor/nodeHashjoin.c   |  2 +-
src/backend/storage/buffer/bufmgr.c   |  8 +++---
src/backend/utils/cache/catcache.c    |  2 +-
src/include/c.h                       |  9 ++++++-
8 files changed, 45 insertions(+), 38 deletions(-)



^ permalink  raw  reply  [nested|flat] 7+ messages in thread

* pgsql: Shorten pg_attribute_always_inline to pg_always_inline
@ 2026-07-11 16:04  Tomas Vondra <tomas.vondra@postgresql.org>
  0 siblings, 0 replies; 7+ messages in thread

From: Tomas Vondra @ 2026-07-11 16:04 UTC (permalink / raw)
  To: pgsql-committers@lists.postgresql.org

Shorten pg_attribute_always_inline to pg_always_inline

The pg_attribute_always_inline macro name is so long it forces pgindent
to format the code in strange ways. Which may incentivize patch authors
to either structure the code in strange ways (e.g. reorder prototypes),
use shorter names, etc. Neither is very desirable for code readability.

This shortens the name by removing the _attribute_ part. It also makes
it more consistent with pg_noinline, which does not have the _attribute_
part either.

Backpatched to all supported branches, to prevent conflicts when
backpatching other fixes. The backbranches however keep both the old and
new macro name, so that existing code keeps working.

Author: Andres Freund <andres@anarazel.de>
Reviewed-by: Peter Geoghegan <pg@bowt.ie>
Reviewed-by: Tomas Vondra <tomas@vondra.me>
Discussion: https://postgr.es/m/bqqdehahpoa36igpictuqyn2s2mexk3t3ehidh2ffd2slb35e5@rzgksuiszgbg
Backpatch-through: 14

Branch
------
REL_16_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/0bb484a7ec5cf7d73baaa7d0cf95f086b7188b3d

Modified Files
--------------
src/backend/executor/execExprInterp.c | 50 +++++++++++++++++------------------
src/backend/executor/execTuples.c     |  6 ++---
src/backend/executor/nodeHashjoin.c   |  2 +-
src/backend/utils/cache/catcache.c    |  2 +-
src/include/c.h                       |  9 ++++++-
5 files changed, 38 insertions(+), 31 deletions(-)



^ permalink  raw  reply  [nested|flat] 7+ messages in thread

* pgsql: Shorten pg_attribute_always_inline to pg_always_inline
@ 2026-07-11 16:04  Tomas Vondra <tomas.vondra@postgresql.org>
  0 siblings, 0 replies; 7+ messages in thread

From: Tomas Vondra @ 2026-07-11 16:04 UTC (permalink / raw)
  To: pgsql-committers@lists.postgresql.org

Shorten pg_attribute_always_inline to pg_always_inline

The pg_attribute_always_inline macro name is so long it forces pgindent
to format the code in strange ways. Which may incentivize patch authors
to either structure the code in strange ways (e.g. reorder prototypes),
use shorter names, etc. Neither is very desirable for code readability.

This shortens the name by removing the _attribute_ part. It also makes
it more consistent with pg_noinline, which does not have the _attribute_
part either.

Backpatched to all supported branches, to prevent conflicts when
backpatching other fixes. The backbranches however keep both the old and
new macro name, so that existing code keeps working.

Author: Andres Freund <andres@anarazel.de>
Reviewed-by: Peter Geoghegan <pg@bowt.ie>
Reviewed-by: Tomas Vondra <tomas@vondra.me>
Discussion: https://postgr.es/m/bqqdehahpoa36igpictuqyn2s2mexk3t3ehidh2ffd2slb35e5@rzgksuiszgbg
Backpatch-through: 14

Branch
------
REL_15_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/494f4f409c0d5866101dc232454e1187d50a84e0

Modified Files
--------------
src/backend/executor/execExprInterp.c | 50 +++++++++++++++++------------------
src/backend/executor/execTuples.c     |  6 ++---
src/backend/executor/nodeHashjoin.c   |  2 +-
src/backend/utils/cache/catcache.c    |  2 +-
src/include/c.h                       |  9 ++++++-
5 files changed, 38 insertions(+), 31 deletions(-)



^ permalink  raw  reply  [nested|flat] 7+ messages in thread

* pgsql: Shorten pg_attribute_always_inline to pg_always_inline
@ 2026-07-11 16:05  Tomas Vondra <tomas.vondra@postgresql.org>
  0 siblings, 0 replies; 7+ messages in thread

From: Tomas Vondra @ 2026-07-11 16:05 UTC (permalink / raw)
  To: pgsql-committers@lists.postgresql.org

Shorten pg_attribute_always_inline to pg_always_inline

The pg_attribute_always_inline macro name is so long it forces pgindent
to format the code in strange ways. Which may incentivize patch authors
to either structure the code in strange ways (e.g. reorder prototypes),
use shorter names, etc. Neither is very desirable for code readability.

This shortens the name by removing the _attribute_ part. It also makes
it more consistent with pg_noinline, which does not have the _attribute_
part either.

Backpatched to all supported branches, to prevent conflicts when
backpatching other fixes. The backbranches however keep both the old and
new macro name, so that existing code keeps working.

Author: Andres Freund <andres@anarazel.de>
Reviewed-by: Peter Geoghegan <pg@bowt.ie>
Reviewed-by: Tomas Vondra <tomas@vondra.me>
Discussion: https://postgr.es/m/bqqdehahpoa36igpictuqyn2s2mexk3t3ehidh2ffd2slb35e5@rzgksuiszgbg
Backpatch-through: 14

Branch
------
REL_14_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/5c1004b0d33426f642808133c282c09cdd0a4f86

Modified Files
--------------
src/backend/executor/execExprInterp.c | 50 +++++++++++++++++------------------
src/backend/executor/execTuples.c     |  6 ++---
src/backend/executor/nodeHashjoin.c   |  2 +-
src/backend/utils/cache/catcache.c    |  2 +-
src/include/c.h                       |  9 ++++++-
5 files changed, 38 insertions(+), 31 deletions(-)



^ permalink  raw  reply  [nested|flat] 7+ messages in thread


end of thread, other threads:[~2026-07-11 16:05 UTC | newest]

Thread overview: 7+ messages (download: mbox mbox.gz follow: Atom feed)
-- links below jump to the message on this page --
2026-07-11 16:03 pgsql: Shorten pg_attribute_always_inline to pg_always_inline Tomas Vondra <tomas.vondra@postgresql.org>
2026-07-11 16:03 pgsql: Shorten pg_attribute_always_inline to pg_always_inline Tomas Vondra <tomas.vondra@postgresql.org>
2026-07-11 16:04 pgsql: Shorten pg_attribute_always_inline to pg_always_inline Tomas Vondra <tomas.vondra@postgresql.org>
2026-07-11 16:04 pgsql: Shorten pg_attribute_always_inline to pg_always_inline Tomas Vondra <tomas.vondra@postgresql.org>
2026-07-11 16:04 pgsql: Shorten pg_attribute_always_inline to pg_always_inline Tomas Vondra <tomas.vondra@postgresql.org>
2026-07-11 16:04 pgsql: Shorten pg_attribute_always_inline to pg_always_inline Tomas Vondra <tomas.vondra@postgresql.org>
2026-07-11 16:05 pgsql: Shorten pg_attribute_always_inline to pg_always_inline Tomas Vondra <tomas.vondra@postgresql.org>

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox