pg.ddx.io pgsql-committers@postgresql.org mailing list archivehelp / color / mirror / Atom feed
pgsql: postgres_fdw: Rename option "restore_stats" to "import_stats". 2+ messages / 1 participants [nested] [flat]
* pgsql: postgres_fdw: Rename option "restore_stats" to "import_stats". @ 2026-08-14 08:50 Etsuro Fujita <efujita@postgresql.org> 0 siblings, 0 replies; 2+ messages in thread From: Etsuro Fujita @ 2026-08-14 08:50 UTC (permalink / raw) To: pgsql-committers@lists.postgresql.org postgres_fdw: Rename option "restore_stats" to "import_stats". The option added by commit 28972b6fc was named "restore_stats", because it was calling pg_restore_relation_stats()/pg_restore_attribute_stats() in place of fetching a remote rowsample. However, those code paths have been replaced with calls to import_relation_statistics()/import_attribute_statistics() (cf. commit 54cd6fc83), so the option is now slightly misnamed. Switch the option to "import_stats", which more closely reflects both the functions being called internally, and the user's perception of what the operation is doing. Back-patch to v19 where commit 28972b6fc went in. Suggested-by: Etsuro Fujita <etsuro.fujita@gmail.com> Author: Corey Huinker <corey.huinker@gmail.com> Discussion: https://postgr.es/m/CADkLM%3DezuspTk3VD-2EM6XtFP-Dfz7cJKtnbn0cB6gocsAgu1g%40mail.gmail.com Backpatch-through: 19 Branch ------ master Details ------- https://git.postgresql.org/pg/commitdiff/9a08585e8e59068d0ede7d47cd037915a42e1362 Modified Files -------------- contrib/postgres_fdw/expected/postgres_fdw.out | 6 +++--- contrib/postgres_fdw/option.c | 8 ++++---- contrib/postgres_fdw/postgres_fdw.c | 16 ++++++++-------- contrib/postgres_fdw/sql/postgres_fdw.sql | 6 +++--- doc/src/sgml/postgres-fdw.sgml | 6 +++--- 5 files changed, 21 insertions(+), 21 deletions(-) ^ permalink raw reply [nested|flat] 2+ messages in thread
* pgsql: postgres_fdw: Rename option "restore_stats" to "import_stats". @ 2026-08-14 08:50 Etsuro Fujita <efujita@postgresql.org> 0 siblings, 0 replies; 2+ messages in thread From: Etsuro Fujita @ 2026-08-14 08:50 UTC (permalink / raw) To: pgsql-committers@lists.postgresql.org postgres_fdw: Rename option "restore_stats" to "import_stats". The option added by commit 28972b6fc was named "restore_stats", because it was calling pg_restore_relation_stats()/pg_restore_attribute_stats() in place of fetching a remote rowsample. However, those code paths have been replaced with calls to import_relation_statistics()/import_attribute_statistics() (cf. commit 54cd6fc83), so the option is now slightly misnamed. Switch the option to "import_stats", which more closely reflects both the functions being called internally, and the user's perception of what the operation is doing. Back-patch to v19 where commit 28972b6fc went in. Suggested-by: Etsuro Fujita <etsuro.fujita@gmail.com> Author: Corey Huinker <corey.huinker@gmail.com> Discussion: https://postgr.es/m/CADkLM%3DezuspTk3VD-2EM6XtFP-Dfz7cJKtnbn0cB6gocsAgu1g%40mail.gmail.com Backpatch-through: 19 Branch ------ REL_19_STABLE Details ------- https://git.postgresql.org/pg/commitdiff/48965e14655a007c1250dbd4a1aba65e478ce929 Modified Files -------------- contrib/postgres_fdw/expected/postgres_fdw.out | 6 +++--- contrib/postgres_fdw/option.c | 8 ++++---- contrib/postgres_fdw/postgres_fdw.c | 16 ++++++++-------- contrib/postgres_fdw/sql/postgres_fdw.sql | 6 +++--- doc/src/sgml/postgres-fdw.sgml | 6 +++--- 5 files changed, 21 insertions(+), 21 deletions(-) ^ permalink raw reply [nested|flat] 2+ messages in thread
end of thread, other threads:[~2026-08-14 08:50 UTC | newest] Thread overview: 2+ messages (download: mbox mbox.gz follow: Atom feed) -- links below jump to the message on this page -- 2026-08-14 08:50 pgsql: postgres_fdw: Rename option "restore_stats" to "import_stats". Etsuro Fujita <efujita@postgresql.org> 2026-08-14 08:50 pgsql: postgres_fdw: Rename option "restore_stats" to "import_stats". Etsuro Fujita <efujita@postgresql.org>
This inbox is served by DDX for PostgreSQL; see mirroring instructions for how to clone and mirror all data and code used for this inbox