pg.ddx.io  pgsql-committers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Etsuro Fujita <efujita@postgresql.org>
To: pgsql-committers@lists.postgresql.org
Subject: pgsql: postgres_fdw: Rename option "restore_stats" to "import_stats".
Date: Fri, 14 Aug 2026 08:50:23 +0000
Message-ID: <E1wuncM-00000000Wty-1uOH@gemulon.postgresql.org> (raw)

postgres_fdw: Rename option "restore_stats" to "import_stats".

The option added by commit 28972b6fc was named "restore_stats", because
it was calling pg_restore_relation_stats()/pg_restore_attribute_stats()
in place of fetching a remote rowsample.  However, those code paths have
been replaced with calls to
import_relation_statistics()/import_attribute_statistics() (cf. commit
54cd6fc83), so the option is now slightly misnamed.

Switch the option to "import_stats", which more closely reflects both
the functions being called internally, and the user's perception of what
the operation is doing.

Back-patch to v19 where commit 28972b6fc went in.

Suggested-by: Etsuro Fujita <etsuro.fujita@gmail.com>
Author: Corey Huinker <corey.huinker@gmail.com>
Discussion: https://postgr.es/m/CADkLM%3DezuspTk3VD-2EM6XtFP-Dfz7cJKtnbn0cB6gocsAgu1g%40mail.gmail.com
Backpatch-through: 19

Branch
------
REL_19_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/48965e14655a007c1250dbd4a1aba65e478ce929

Modified Files
--------------
contrib/postgres_fdw/expected/postgres_fdw.out |  6 +++---
contrib/postgres_fdw/option.c                  |  8 ++++----
contrib/postgres_fdw/postgres_fdw.c            | 16 ++++++++--------
contrib/postgres_fdw/sql/postgres_fdw.sql      |  6 +++---
doc/src/sgml/postgres-fdw.sgml                 |  6 +++---
5 files changed, 21 insertions(+), 21 deletions(-)



view thread (2+ messages)  latest in thread

Message-ID: <E1wuncM-00000000Wty-1uOH@gemulon.postgresql.org>
Permalink:  ../E1wuncM-00000000Wty-1uOH@gemulon.postgresql.org/
Also on:    postgresql.org/message-id/E1wuncM-00000000Wty-1uOH@gemulon.postgresql.org

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-committers@postgresql.org
  Cc: efujita@postgresql.org, pgsql-committers@lists.postgresql.org
  Subject: Re: pgsql: postgres_fdw: Rename option "restore_stats" to "import_stats".
  In-Reply-To: <E1wuncM-00000000Wty-1uOH@gemulon.postgresql.org>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox