public inbox for [email protected]
help / color / mirror / Atom feedFrom: Fujii Masao <[email protected]>
To: Daniel Gustafsson <[email protected]>
Cc: [email protected] <[email protected]>
Subject: Re: Fix data checksum progress reporting docs
Date: Fri, 10 Jul 2026 10:13:21 +0900
Message-ID: <CAHGQGwFsBjQs2fv7b72hxzGV_fJMh6LAg4E83pNfDOu1jVgWCA@mail.gmail.com> (raw)
In-Reply-To: <[email protected]>
References: <CAHGQGwHJHJYAkYZBi3_O13np-Rou9UL637=hB3Y_-qdCgcZn-w@mail.gmail.com>
<[email protected]>
<CAHGQGwEv-C9ia+rBYyePzO8F=5FVvS412ZqcOupazuOb5RafNg@mail.gmail.com>
<[email protected]>
On Thu, Jul 9, 2026 at 5:28 PM Daniel Gustafsson <[email protected]> wrote:
> You are absolutely right. And when looking at it I think we can simplify the
> entry a bit as well to make it fit the style of the page better. What do you
> think about the attached?
Thanks for the patch! I like the overall approach.
I just have a few minor comments.
+ A set of
+ <glossterm linkend="glossary-background-worker">background
worker</glossterm>
+ processes which can enable, or disable, data checksums in a
Wouldn't it be better to remove the two commas here?
+ running cluster. The process which coordinates the work is known as the
+ <firstterm>data checksums worker launcher</firstterm> and the process
Only the glossary seems to use the term "data checksums worker launcher".
Wouldn't "data checksums launcher" (i.e., dropping "worker") be a better name?
+ <firstterm>data checksums worker launcher</firstterm> and the process
+ which operate on the individual databases is known as the
+ <firstterm>data checksums worker</firstterm>.
Shouldn't "the process which operate" be either "the process which operates"
or "the processes which operate"? Since multiple data checksums workers
can run, the latter seems more appropriate.
While looking at the related code, I also found that
B_DATACHECKSUMSWORKER_LAUNCHER and B_DATACHECKSUMSWORKER_WORKER
were added as BackendType entries in miscadmin.h. Since those entries appear
under the comment for auxiliary processes, it could give the impression that
the data checksums launcher and workers are auxiliary processes. To avoid
that confusion, would it make sense to add a comment such as:
-------------------------
B_WAL_WRITER,
+ /*
+ * XXXXXXXXXX
+ */
B_DATACHECKSUMSWORKER_LAUNCHER,
B_DATACHECKSUMSWORKER_WORKER,
-------------------------
BTW, I'm also wondering why dedicated BackendType entries were added for
the data checksums processes, while other background workers don't have
their own BackendType values.
Regards,
--
Fujii Masao
view thread (7+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected]
Subject: Re: Fix data checksum progress reporting docs
In-Reply-To: <CAHGQGwFsBjQs2fv7b72hxzGV_fJMh6LAg4E83pNfDOu1jVgWCA@mail.gmail.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox