agora inbox for pgsql-docs@postgresql.org  
help / color / mirror / Atom feed
From: Gurjeet Singh <gurjeet@singh.im>
To: Tom Lane <tgl@sss.pgh.pa.us>
To: postgresql@complexity.com.au
Cc: pgsql-docs@lists.postgresql.org
Subject: Re: Creating first database
Date: Sat, 29 Mar 2025 07:56:48 -0700
Message-ID: <D8SU63UEWM2W.2G7T8VNS82WBH@singh.im> (raw)
In-Reply-To: <2689845.1743256570@sss.pgh.pa.us>
References: <174322916469.674.13909966511923455324@wrigleys.postgresql.org>
	<2689845.1743256570@sss.pgh.pa.us>

On Sat Mar 29, 2025 at 6:56 AM PDT, Tom Lane wrote:
> PG Doc comments form <noreply@postgresql.org> writes:
>> In the Getting Started section of the documentation which would be used by a
>> new user immediately after installing PostgreSQL, the user is asked to run
>> $ createdb mydb
>> If the database is correctly installed, this first command to be run by the
>> new user inevitably fails with the error:
>> createdb: error: connection to server at "localhost" (::1), port 5432
>> failed: FATAL:  password authentication failed for user "Mark"


> We can't really hope to document everything that every packager does
> in the community Postgres documentation, not least because they seldom
> inform us.  I suppose it might be helpful to add something along the
> lines of "if you are using a pre-packaged version of Postgres, please
> consult the packager's documentation".

Given that the 'Installation' subsection, before the 'Creating a
Database' subsection within Getting Started, covers the various way
Postgres may be installed, and covers that environment variables may
need to be tweaked to accommodated the differences, I don't feel the
subsequent sections need to repeat how to deal with different types of
installations.

Best regards,
Gurjeet
https://Gurje.et






view thread (5+ messages)

Message-ID: <D8SU63UEWM2W.2G7T8VNS82WBH@singh.im>
Permalink:  ../D8SU63UEWM2W.2G7T8VNS82WBH@singh.im/
Also on:    postgresql.org/message-id/D8SU63UEWM2W.2G7T8VNS82WBH@singh.im

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-docs@postgresql.org
  Cc: gurjeet@singh.im, tgl@sss.pgh.pa.us, postgresql@complexity.com.au, pgsql-docs@lists.postgresql.org
  Subject: Re: Creating first database
  In-Reply-To: <D8SU63UEWM2W.2G7T8VNS82WBH@singh.im>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox