From: Oleg <o.sibiryakov@postgrespro.ru>
To: pgsql-docs@lists.postgresql.org
Subject: Documentation improvement patch
Date: Fri, 9 Oct 2026 15:46:36 +0300
Message-ID: <ba30ee2f-d6f3-4116-8c2b-c353a84b5cc8@postgrespro.ru> (raw)
Dear all,
I have prepared a patch containing some minor inconsistencies in the
documentation. Please, take a look.
I will be looking forward to your feedback.
The patch shall be applied to the master branch.
--
Regards,
Oleg Sibiryakov
Technical Writer
Postgres Professional, The Russian Postgres Company
https://postgrespro.ruAttachments:
[text/x-patch] doc_improvements_postgresql_19.patch (47.6K, ../ba30ee2f-d6f3-4116-8c2b-c353a84b5cc8@postgrespro.ru/3-doc_improvements_postgresql_19.patch)
download | inline diff:diff --git a/doc/src/sgml/advanced.sgml b/doc/src/sgml/advanced.sgmlindex 3286c2cf0b2..6c2ca4aaead 100644--- a/doc/src/sgml/advanced.sgml+++ b/doc/src/sgml/advanced.sgml@@ -258,8 +258,8 @@ COMMIT;
</note>
<para>
- When an error occurs within a transaction block the transaction is not- ended, but instead goes into an aborted state. While in this state all+ When an error occurs within a transaction block, the transaction is not+ ended but instead goes into an aborted state. While in this state, all
commands except <xref linkend="sql-commit"/> and
<xref linkend="sql-rollback"/> are rejected. Importantly, both those
commands will behave identically — they roll back and close the
diff --git a/doc/src/sgml/config.sgml b/doc/src/sgml/config.sgmlindex 0165eb9ec02..ee62a3084b4 100644--- a/doc/src/sgml/config.sgml+++ b/doc/src/sgml/config.sgml@@ -1775,7 +1775,7 @@ include_dir 'conf.d'
</term>
<listitem>
<para>
- Enables SNI configuration for SSL connections. When set to <literal>on</literal>+ Enables SNI configuration for SSL connections. When set to <literal>on</literal>,
host configuration from <xref linkend="guc-hosts-file"/> is used, see
<xref linkend="ssl-sni"/> for more details.
</para>
@@ -3040,7 +3040,7 @@ include_dir 'conf.d'
<listitem>
<para>
Sets the time after which entirely idle I/O worker processes exit, reducing the
- size of pool to match demand. The default is 1 minute. This+ size of the pool to match demand. The default is 1 minute. This
parameter can only be set in the
<filename>postgresql.conf</filename> file or on the server command
line.
@@ -7971,7 +7971,7 @@ local0.* /var/log/postgresql
</term>
<listitem>
<para>
- Causes analyze action executed by autovacuum to be logged if it ran for at+ Causes each analyze action executed by autovacuum to be logged if it ran for at
least the specified amount of time. Setting this to zero logs
all analyze actions by autovacuum. <literal>-1</literal> disables logging
analyze actions by autovacuum. If this value is specified without units,
diff --git a/doc/src/sgml/fdwhandler.sgml b/doc/src/sgml/fdwhandler.sgmlindex 502441fefcb..691d6ac4532 100644--- a/doc/src/sgml/fdwhandler.sgml+++ b/doc/src/sgml/fdwhandler.sgml@@ -1429,14 +1429,14 @@ ImportForeignStatistics(Relation relation,
level to use.
If the function imports the statistics successfully, it should return
<literal>true</literal>. Otherwise, return <literal>false</literal>, in
- which case <function>AnalyzeForeignTable</function> callback function is+ which case the <function>AnalyzeForeignTable</function> callback function is
called on the foreign table to generate statistics locally, if supported.
</para>
<para>
For reference, the logic for calculating statistics in
<productname>PostgreSQL</productname> is found in
- <filename>src/backend/command/analyze.c</filename>.+ <filename>src/backend/commands/analyze.c</filename>.
It's recommended to import table-level and column-level statistics for the
foreign table using <function>import_relation_statistics</function>,
<function>import_attribute_statistics</function>, and
diff --git a/doc/src/sgml/func/func-admin.sgml b/doc/src/sgml/func/func-admin.sgmlindex 64b0e7bb972..6148654e717 100644--- a/doc/src/sgml/func/func-admin.sgml+++ b/doc/src/sgml/func/func-admin.sgml@@ -1492,7 +1492,7 @@ postgres=# SELECT '0/0'::pg_lsn + pd.segment_number * ps.setting::int + :offset
<returnvalue>void</returnvalue>
</para>
<para>
- Synchronize the logical failover replication slots from the primary+ Synchronizes the logical failover replication slots from the primary
server to the standby server. This function can only be executed on the
standby server. Temporary synced slots, if any, cannot be used for
logical decoding and must be dropped after promotion. This function
diff --git a/doc/src/sgml/func/func-aggregate.sgml b/doc/src/sgml/func/func-aggregate.sgmlindex 6a6a4d7e32e..7357bcb7d76 100644--- a/doc/src/sgml/func/func-aggregate.sgml+++ b/doc/src/sgml/func/func-aggregate.sgml@@ -432,7 +432,7 @@
are coerced to text; value arguments are converted as per
<function>to_json</function> or <function>to_jsonb</function>.
The <parameter>key</parameter> cannot be null. If the
- <parameter>value</parameter> is null then the entry is skipped,+ <parameter>value</parameter> is null, then the entry is skipped.
</para></entry>
<entry>No</entry>
</row>
@@ -461,7 +461,7 @@
are coerced to text; value arguments are converted as per
<function>to_json</function> or <function>to_jsonb</function>.
Values can be null, but keys cannot.
- If there is a duplicate key an error is thrown.+ If there is a duplicate key, an error is thrown.
</para></entry>
<entry>No</entry>
</row>
@@ -490,8 +490,8 @@
are coerced to text; value arguments are converted as per
<function>to_json</function> or <function>to_jsonb</function>.
The <parameter>key</parameter> cannot be null. If the
- <parameter>value</parameter> is null then the entry is skipped.- If there is a duplicate key an error is thrown.+ <parameter>value</parameter> is null, then the entry is skipped.+ If there is a duplicate key, an error is thrown.
</para></entry>
<entry>No</entry>
</row>
diff --git a/doc/src/sgml/func/func-array.sgml b/doc/src/sgml/func/func-array.sgmlindex 7f162bd7670..24efef60bc6 100644--- a/doc/src/sgml/func/func-array.sgml+++ b/doc/src/sgml/func/func-array.sgml@@ -145,7 +145,7 @@
<para>
<xref linkend="array-functions-table"/> shows the functions
available for use with array types. See <xref linkend="arrays"/>
- for more information and examples of the use of these functions.+ for more information and examples of the use of these functions.
</para>
<table id="array-functions-table">
diff --git a/doc/src/sgml/func/func-json.sgml b/doc/src/sgml/func/func-json.sgmlindex f8ff4355a31..3a24b8ef44f 100644--- a/doc/src/sgml/func/func-json.sgml+++ b/doc/src/sgml/func/func-json.sgml@@ -2789,7 +2789,7 @@ ERROR: jsonpath member accessor can only be applied to an object
<returnvalue><replaceable>string</replaceable></returnvalue>
</para>
<para>
- String converted to all lower case according to the rules of the database's locale.+ String converted to all lower case according to the rules of the database's locale
</para>
<para>
<literal>jsonb_path_query('"TOM"', '$.lower()')</literal>
@@ -2803,7 +2803,7 @@ ERROR: jsonpath member accessor can only be applied to an object
<returnvalue><replaceable>string</replaceable></returnvalue>
</para>
<para>
- String converted to all upper case according to the rules of the database's locale.+ String converted to all upper case according to the rules of the database's locale
</para>
<para>
<literal>jsonb_path_query('"tom"', '$.upper()')</literal>
@@ -2819,7 +2819,7 @@ ERROR: jsonpath member accessor can only be applied to an object
<para>
String with the first letter of each word converted to upper case
according to the rules of the database's locale. Words are sequences
- of alphanumeric characters separated by non-alphanumeric characters.+ of alphanumeric characters separated by non-alphanumeric characters
</para>
<para>
<literal>jsonb_path_query('"hi THOMAS"', '$.initcap()')</literal>
@@ -2833,7 +2833,7 @@ ERROR: jsonpath member accessor can only be applied to an object
<returnvalue><replaceable>string</replaceable></returnvalue>
</para>
<para>
- String with all occurrences of substring from replaced with substring to.+ String with all occurrences of substring from replaced with substring to
</para>
<para>
<literal>jsonb_path_query('"abcdefabcdef"', '$.replace("cd", "XX")')</literal>
@@ -2850,7 +2850,7 @@ ERROR: jsonpath member accessor can only be applied to an object
String split at occurrences of <replaceable>delimiter</replaceable>
and returns the <replaceable>n</replaceable>'th field (counting from
one) or, when <replaceable>n</replaceable> is negative, returns the
- |<replaceable>n</replaceable>|'th-from-last field.+ |<replaceable>n</replaceable>|'th-from-last field
</para>
<para>
<literal>jsonb_path_query('"abc~@~def~@~ghi"', '$.split_part("~@~", 2)')</literal>
@@ -2868,7 +2868,7 @@ ERROR: jsonpath member accessor can only be applied to an object
<returnvalue><replaceable>string</replaceable></returnvalue>
</para>
<para>
- String with the longest string containing only spaces or the+ String with the longest substring containing only spaces or the
characters in <replaceable>characters</replaceable> removed from the
start of <replaceable>string</replaceable>
</para>
@@ -2888,7 +2888,7 @@ ERROR: jsonpath member accessor can only be applied to an object
<returnvalue><replaceable>string</replaceable></returnvalue>
</para>
<para>
- String with the longest string containing only spaces or the+ String with the longest substring containing only spaces or the
characters in <replaceable>characters</replaceable> removed from the
end of <replaceable>string</replaceable>
</para>
@@ -2908,7 +2908,7 @@ ERROR: jsonpath member accessor can only be applied to an object
<returnvalue><replaceable>string</replaceable></returnvalue>
</para>
<para>
- String with the longest string containing only spaces or the+ String with the longest substring containing only spaces or the
characters in <replaceable>characters</replaceable> removed from the
start and end of <replaceable>string</replaceable>
</para>
@@ -3318,7 +3318,7 @@ $.* ? (@ like_regex "^\\d+$")
SQL/JSON functions <literal>JSON_EXISTS()</literal>,
<literal>JSON_QUERY()</literal>, and <literal>JSON_VALUE()</literal>
described in <xref linkend="functions-sqljson-querying"/> can be used
- to query JSON documents. Each of these functions apply a+ to query JSON documents. Each of these functions applies a
<replaceable>path_expression</replaceable> (an SQL/JSON path query) to a
<replaceable>context_item</replaceable> (the document). See
<xref linkend="functions-sqljson-path"/> for more details on what
diff --git a/doc/src/sgml/func/func-matching.sgml b/doc/src/sgml/func/func-matching.sgmlindex ae1dff66722..fd5410db97d 100644--- a/doc/src/sgml/func/func-matching.sgml+++ b/doc/src/sgml/func/func-matching.sgml@@ -2337,7 +2337,7 @@ SELECT regexp_match('abc01234xyz', '(?:(.*?)(\d+)(.*)){1,1}');
<para>
Since SQL:2008, the SQL standard includes regular expression operators
- and functions that performs pattern+ and functions that perform pattern
matching according to the XQuery regular expression
standard:
<itemizedlist>
diff --git a/doc/src/sgml/glossary.sgml b/doc/src/sgml/glossary.sgmlindex d28a3729188..722f742db19 100644--- a/doc/src/sgml/glossary.sgml+++ b/doc/src/sgml/glossary.sgml@@ -593,9 +593,9 @@
<para>
A set of
<glossterm linkend="glossary-background-worker">background worker</glossterm>
- processes which can enable or disable data checksums in a running cluster.- The process which coordinates the work is known as the- <firstterm>data checksums launcher</firstterm> and the process which+ processes that can enable or disable data checksums in a running cluster.+ The process that coordinates the work is known as the+ <firstterm>data checksums launcher</firstterm> and the process that
operates on the individual databases is known as the
<firstterm>data checksums worker</firstterm>.
</para>
diff --git a/doc/src/sgml/libpq.sgml b/doc/src/sgml/libpq.sgmlindex 68487a3954f..657d3702606 100644--- a/doc/src/sgml/libpq.sgml+++ b/doc/src/sgml/libpq.sgml@@ -10572,7 +10572,7 @@ PGOAUTHDEBUG=UNSAFE <lineannotation>legacy format; enables
<listitem>
<para>
Prints the total number of calls to the flow plugin to standard error
- when the OAuth flow completes. This helps developers debug the async+ when the OAuth flow completes. This helps developers debug asynchronous
callback behavior.
</para>
</listitem>
diff --git a/doc/src/sgml/logical-replication.sgml b/doc/src/sgml/logical-replication.sgmlindex 4701a3d9d18..c6a7aa9b20e 100644--- a/doc/src/sgml/logical-replication.sgml+++ b/doc/src/sgml/logical-replication.sgml@@ -2876,7 +2876,7 @@ CONTEXT: processing remote data for replication origin "pg_16395" during "INSER
<link linkend="sql-createsubscription-params-with-retain-dead-tuples"><literal>retain_dead_tuples</literal></link>
is enabled, the upgraded subscriber may be unable to detect conflicts or
log relevant commit timestamps and origins when applying changes from the
- publisher occurred before the upgrade. Additionally, immediately after the+ publisher that occurred before the upgrade. Additionally, immediately after the
upgrade, the vacuum may remove the deleted rows that are required for
conflict detection. This can affect the changes that were not replicated
before the upgrade. To ensure consistent conflict tracking, users should
diff --git a/doc/src/sgml/logicaldecoding.sgml b/doc/src/sgml/logicaldecoding.sgmlindex 6dc49108997..11723c1424e 100644--- a/doc/src/sgml/logicaldecoding.sgml+++ b/doc/src/sgml/logicaldecoding.sgml@@ -674,7 +674,7 @@ DETAIL: Synchronization could lead to data loss, because the remote slot needs
<para>
A comma-separated list of publication names to subscribe to.
The individual publication names are treated
- as standard objects names and can be quoted the same as needed.+ as standard object names and can be quoted the same as needed.
At least one publication name is required.
</para>
</listitem>
@@ -734,7 +734,7 @@ DETAIL: Synchronization could lead to data loss, because the remote slot needs
<listitem>
<para>
Enables sending two-phase transactions.
- Minimum protocol version 3 is required to turn it on.+ This requires protocol version 3 or higher.
The default is <literal>off</literal>.
</para>
</listitem>
diff --git a/doc/src/sgml/maintenance.sgml b/doc/src/sgml/maintenance.sgmlindex 137175ca3b5..80663d40137 100644--- a/doc/src/sgml/maintenance.sgml+++ b/doc/src/sgml/maintenance.sgml@@ -855,7 +855,7 @@ HINT: Execute a database-wide VACUUM in that database.
running <literal>UPDATE</literal> statements with foreign key checks,
concurrent <literal>SELECT FOR SHARE</literal> operations, or frequent
use of savepoints causing lock contention.
- If <literal>oldest_multixact</literal> value remains unchanged while+ If the <literal>oldest_multixact</literal> value remains unchanged while
<literal>num_members</literal> grows, it could indicate that long-running
transactions are preventing cleanup, or autovacuum is
not keeping up with the workload.
@@ -1180,7 +1180,7 @@ analyze threshold = analyze base threshold + analyze scale factor * number of tu
<productname>PostgreSQL</productname> 19 (i.e., the order the tables are
listed in the <literal>pg_class</literal> system catalog), set all of the
aforementioned "weight" parameters to <literal>0.0</literal>. Otherwise,
- these "weight" parameters are multiplied to their respective component+ these "weight" parameters are multiplied by their respective component
scores. For example, raising
<xref linkend="guc-autovacuum-analyze-score-weight"/> to
<literal>2.0</literal> effectively doubles the
diff --git a/doc/src/sgml/monitoring.sgml b/doc/src/sgml/monitoring.sgmlindex 0d038de1a23..b5c3c7f451d 100644--- a/doc/src/sgml/monitoring.sgml+++ b/doc/src/sgml/monitoring.sgml@@ -4849,7 +4849,7 @@ description | Waiting for a newly initialized WAL file to reach durable storage
<structfield>relid</structfield> <type>oid</type>
</para>
<para>
- Oid of the table.+ OID of the table.
</para></entry>
</row>
@@ -7095,7 +7095,7 @@ FROM pg_stat_get_backend_idset() AS backendid;
<para>
Number of tuples skipped because they contain malformed data.
This counter only advances when
- <literal>ignore</literal> is specified to the <literal>ON_ERROR</literal>+ <literal>ignore</literal> is specified for the <literal>ON_ERROR</literal>
option.
</para></entry>
</row>
diff --git a/doc/src/sgml/oauth-validators.sgml b/doc/src/sgml/oauth-validators.sgmlindex 6c4a4f94769..1071115a355 100644--- a/doc/src/sgml/oauth-validators.sgml+++ b/doc/src/sgml/oauth-validators.sgml@@ -117,7 +117,7 @@
That is, "trusted" in the sense that the OAuth client and the
<productname>PostgreSQL</productname> server are controlled by the same
entity. Notably, the Device Authorization client flow supported by
- libpq does not usually meet this bar, since it's designed for use by+ libpq does not usually meet this bar, since it is designed for use by
public/untrusted clients.
</para>
</footnote>
@@ -433,7 +433,7 @@ typedef struct ValidatorModuleResult
<sect2 id="oauth-validator-callback-shutdown">
<title>Shutdown Callback</title>
<para>
- The <function>shutdown_cb</function> callback is executed when the server+ The <function>shutdown_cb</function> callback is executed when the
backend has finished validating tokens for the connection. If the validator
module has any allocated state, this callback should free it to avoid
resource leaks.
@@ -505,7 +505,7 @@ void RegisterOAuthHBAOptions(ValidatorModuleState *state, int num,
<programlisting>
/*
- * Retrieve the string value of an HBA option which was registered via+ * Retrieve the string value of an HBA option, which was registered via
* RegisterOAuthHBAOptions(). Usable only during validate_cb or shutdown_cb.
*
* If the user has set the corresponding option in pg_hba.conf, this function
@@ -554,7 +554,7 @@ const char *GetOAuthHBAOption(const ValidatorModuleState *state,
<footnote>
<para>
If a module finds an invalid option value during <function>validate_cb</function>,
- it's recommended to <link linkend="oauth-validator-callback-validate">signal+ it is recommended to <link linkend="oauth-validator-callback-validate">signal
an internal error</link> by setting <structfield>result->error_detail</structfield>
to a description of the problem and returning <literal>false</literal>.
</para>
diff --git a/doc/src/sgml/oid2name.sgml b/doc/src/sgml/oid2name.sgmlindex 9340d7376aa..59e59613cd8 100644--- a/doc/src/sgml/oid2name.sgml+++ b/doc/src/sgml/oid2name.sgml@@ -93,7 +93,7 @@
<term><option>-S</option></term>
<term><option>--system-objects</option></term>
<listitem><para>include system objects (those in
- <option>information_schema</option>, <option>pg_toast</option>+ <option>information_schema</option>, <option>pg_toast</option>,
and <option>pg_catalog</option> schemas).
</para></listitem>
</varlistentry>
@@ -118,7 +118,7 @@
<term><option>-x</option></term>
<term><option>--extended</option></term>
<listitem><para>display more information about each object shown: tablespace name,
- schema name, OID and path.+ schema name, OID, and path.
</para></listitem>
</varlistentry>
@@ -176,7 +176,7 @@
<para>
To display specific tables, select which tables to show by
- using <option>-o</option>, <option>-f</option> and/or <option>-t</option>.+ using <option>-o</option>, <option>-f</option>, and/or <option>-t</option>.
<option>-o</option> takes an OID,
<option>-f</option> takes a filenode,
and <option>-t</option> takes a table name (actually, it's a <literal>LIKE</literal>
@@ -227,7 +227,7 @@
<para>
The environment variable <envar>PG_COLOR</envar> specifies whether to use
color in diagnostic messages. Possible values are
- <literal>always</literal>, <literal>auto</literal> and+ <literal>always</literal>, <literal>auto</literal>, and
<literal>never</literal>.
</para>
</refsect1>
diff --git a/doc/src/sgml/parallel.sgml b/doc/src/sgml/parallel.sgmlindex af43484703e..e1731fb3b66 100644--- a/doc/src/sgml/parallel.sgml+++ b/doc/src/sgml/parallel.sgml@@ -301,8 +301,8 @@ EXPLAIN SELECT * FROM pgbench_accounts WHERE filler LIKE '%x%';
</listitem>
<listitem>
<para>
- In a <emphasis>parallel tid range scan</emphasis>, the range of blocks- will be subdivided into smaller ranges which are shared among the+ In a <emphasis>parallel TID range scan</emphasis>, the range of blocks+ will be subdivided into smaller ranges, which are shared among the
cooperating processes. Each worker process will complete the scanning
of its given range of blocks before requesting an additional range of
blocks.
diff --git a/doc/src/sgml/pgbuffercache.sgml b/doc/src/sgml/pgbuffercache.sgmlindex 1e9aee10275..d009c49e65b 100644--- a/doc/src/sgml/pgbuffercache.sgml+++ b/doc/src/sgml/pgbuffercache.sgml@@ -56,19 +56,19 @@
</indexterm>
<para>
- This module provides the <function>pg_buffercache_pages()</function>- function (wrapped in the <structname>pg_buffercache</structname> view), the- <function>pg_buffercache_os_pages()</function> function (wrapped in the+ This module provides the following functions: <function>pg_buffercache_pages()</function>+ (wrapped in the <structname>pg_buffercache</structname> view),+ <function>pg_buffercache_os_pages()</function> (wrapped in the
<structname>pg_buffercache_os_pages</structname> and
- <structname>pg_buffercache_numa</structname> views), the- <function>pg_buffercache_summary()</function> function, the- <function>pg_buffercache_usage_counts()</function> function, the- <function>pg_buffercache_evict()</function> function, the- <function>pg_buffercache_evict_relation()</function> function, the- <function>pg_buffercache_evict_all()</function> function, the- <function>pg_buffercache_mark_dirty()</function> function, the- <function>pg_buffercache_mark_dirty_relation()</function> function and the- <function>pg_buffercache_mark_dirty_all()</function> function.+ <structname>pg_buffercache_numa</structname> views),+ <function>pg_buffercache_summary()</function>,+ <function>pg_buffercache_usage_counts()</function>,+ <function>pg_buffercache_evict()</function>,+ <function>pg_buffercache_evict_relation()</function>,+ <function>pg_buffercache_evict_all()</function>,+ <function>pg_buffercache_mark_dirty()</function>,+ <function>pg_buffercache_mark_dirty_relation()</function>, and+ <function>pg_buffercache_mark_dirty_all()</function>.
</para>
<para>
@@ -80,7 +80,7 @@
<para>
The <function>pg_buffercache_os_pages()</function> function provides OS
- pages mappings for shared buffer entries. When its argument is+ page mappings for shared buffer entries. When its argument is
<literal>true</literal>, it also provides <acronym>NUMA</acronym> node
mappings for shared buffer entries (this information is not part of
<function>pg_buffercache_pages()</function> itself, as it is much
@@ -626,10 +626,10 @@
column of the <structname>pg_buffercache</structname> view. It returns
information about whether the buffer was marked as dirty.
The <structfield>buffer_dirtied</structfield> column is true on success,
- and false if the buffer was already dirty if the buffer was not valid or+ and false if the buffer was already dirty, if the buffer was not valid, or
if it could not be marked as dirty because it was pinned.
The <structfield>buffer_already_dirty</structfield> column is true if
- the buffer couldn't be marked as dirty because it was already dirty. The+ the buffer could not be marked as dirty because it was already dirty. The
result is immediately out of date upon return, as the buffer might become
valid again at any time due to concurrent activity. The function is
intended for developer testing only.
@@ -647,7 +647,7 @@
relation identifier instead of buffer identifier. It tries to mark all
buffers dirty for all forks in that relation.
It returns the number of buffers marked as dirty, the number of buffers
- already dirty and the number of buffers skipped because already pinned or+ already dirty, and the number of buffers skipped because they are already pinned or
invalid.
The result is immediately out of date upon return, as the buffer might
become valid again at any time due to concurrent activity. The function is
@@ -665,7 +665,7 @@
<function>pg_buffercache_mark_dirty_all()</function> tries to mark all
buffers dirty in the buffer pool.
It returns the number of buffers marked as dirty, the number of buffers
- already dirty and the number of buffers skipped because already pinned or+ already dirty, and the number of buffers skipped because already pinned or
invalid.
The result is immediately out of date upon return, as the buffer might
become valid again at any time due to concurrent activity. The function is
diff --git a/doc/src/sgml/pgplanadvice.sgml b/doc/src/sgml/pgplanadvice.sgmlindex 4592a5ced54..2a0883aeb4c 100644--- a/doc/src/sgml/pgplanadvice.sgml+++ b/doc/src/sgml/pgplanadvice.sgml@@ -84,9 +84,9 @@ EXPLAIN (COSTS OFF, PLAN_ADVICE)
<para>
Once you have an advice string for a query, you can use it to control how
that query is planned. You can do this by setting
- <literal>pg_plan_advice.advice</literal> to the advice string you've+ <literal>pg_plan_advice.advice</literal> to the advice string you have
chosen. This can be an advice string that was generated by the system,
- or one you've written yourself. One good way of creating your own advice+ or one you have written yourself. One good way of creating your own advice
string is to take the string generated by the system and pick out just
those elements that you wish to enforce. In the example above,
<literal>pg_plan_advice</literal> emits advice for the join order, the
@@ -142,15 +142,15 @@ EXPLAIN (COSTS OFF)
planner still fails to produce the desired plan, this means that either
there is a bug in your advice string, or the plan in question was not
considered viable by the core planner. This commonly happens for one of two
- reasons. First, it might be that the planner believes that the plan you're- trying to force would be semantically incorrect - that is, it would produce- the wrong results - and for that reason it wasn't considered. Second, it+ reasons. First, it might be that the planner believes that the plan you are+ trying to force would be semantically incorrect, that is, it would produce+ the wrong results, and for that reason it was not considered. Second, it
might be that the planner rejected the plan you were hoping to generate on
some grounds other than cost. For example, given a very simple query such as
<literal>SELECT * FROM some_table</literal>, the query planner will
decide that the use of an index is worthless here before it performs any
costing calculations. You cannot force it to use an index for this query
- even if you set <literal>enable_seqscan = false</literal>, and you can't+ even if you set <literal>enable_seqscan = false</literal>, and you cannot
force it to use an index using plan advice, either.
</para>
@@ -182,9 +182,9 @@ EXPLAIN (COSTS OFF)
Because neither <literal>f</literal> nor <literal>d</literal> is the
first table in the <literal>JOIN_ORDER()</literal> specification, the
planner disables all direct joins between the two of them, thinking that
- the join to <literal>x</literal> should happen first. Since planning isn't+ the join to <literal>x</literal> should happen first. Since planning is not
allowed to fail, a disabled plan between the two relations is eventually
- selected anyway, but here it's a <literal>Nested Loop</literal> rather than+ selected anyway, but here it is a <literal>Nested Loop</literal> rather than
the <literal>Hash Join</literal> that was chosen in the above example where
no advice was specified. There are several different ways that this kind
of thing can happen; when it does, the resulting plan is generally worse
@@ -402,7 +402,7 @@ join_method_name(<replaceable>join_method_item</replaceable> [ ... ])
( <replaceable>advice_target</replaceable> [ ... ] ) }</synopsis>
<para>
- Join method advice specifies the relation, or set of relations, that should+ Join method advice specifies the relation or set of relations that should
appear on the inner side of a join using the named join method. For
example, <literal>HASH_JOIN(a b)</literal> means that each of
<literal>a</literal> and <literal>b</literal> should appear on the inner
@@ -504,14 +504,14 @@ NO_GATHER(<replaceable>advice_target</replaceable> [ ... ])
<literal>NO_GATHER</literal> specifies that no <literal>Gather</literal> or
<literal>Gather Merge</literal> node should appear above any of the
targets, but it only constrains the planning of an individual subquery,
- and outer subquery levels can still use parallel query. For example,+ and outer subquery levels can still use parallel queries. For example,
<literal>NO_GATHER(inner_example@any_1)</literal> precludes using a
<literal>Parallel Seq Scan</literal> to access the
<literal>inner_example</literal> table within the <literal>any_1</literal>
subquery, but it does not prevent the planner from placing
<literal>SubPlan any_1</literal> beneath a <literal>Gather</literal>
or <literal>Gather Merge</literal> node. The following plan is
- compatible with <literal>NO_GATHER(inner_example@any_1)</literal>, but+ compatible with <literal>NO_GATHER(inner_example@any_1)</literal> but
not with <literal>NO_GATHER(outer_example)</literal>:
</para>
@@ -624,7 +624,7 @@ EXPLAIN (COSTS OFF)
<para>
<literal>not matched</literal> means that none of the
specified advice targets were observed during query planning. This may
- happen if the advice simply doesn't match the query, or it may+ happen if the advice does not match the query, or it may
occur if the relevant portion of the query was not planned, perhaps
because it was gated by a condition that was simplified to constant false.
</para>
@@ -691,8 +691,7 @@ EXPLAIN (COSTS OFF)
<listitem>
<para>
- <varname>pg_plan_advice.advice</varname> is an advice string to be- used during query planning.+ Specifies an advice string to be used during query planning.
</para>
</listitem>
</varlistentry>
@@ -707,8 +706,7 @@ EXPLAIN (COSTS OFF)
<listitem>
<para>
- <varname>pg_plan_advice.always_explain_supplied_advice</varname> causes- <literal>EXPLAIN</literal> to always show any supplied advice and the+ Causes <literal>EXPLAIN</literal> to always show any supplied advice and the
associated
<link linkend="pgplanadvice-feedback">advice feedback</link>.
The default value is <literal>true</literal>. If set to
@@ -728,8 +726,7 @@ EXPLAIN (COSTS OFF)
<listitem>
<para>
- <varname>pg_plan_advice.always_store_advice_details</varname> allows- <literal>EXPLAIN</literal> to show details related to plan advice even+ Allows <literal>EXPLAIN</literal> to show details related to plan advice even
when prepared queries are used. The default value is
<literal>false</literal>. When planning a prepared query, it is not
possible to know whether <literal>EXPLAIN</literal> will later be used,
@@ -754,7 +751,7 @@ EXPLAIN (COSTS OFF)
<listitem>
<para>
- When set to true, <varname>pg_plan_advice.feedback_warnings</varname>+ When set to true, this parameter
emits a warning whenever supplied plan advice is not successfully
enforced. The default value is <literal>false</literal>.
</para>
@@ -771,9 +768,8 @@ EXPLAIN (COSTS OFF)
<listitem>
<para>
- When <varname>pg_plan_advice.trace_mask</varname> is- <literal>true</literal>, <literal>pg_plan_advice</literal> will print- messages during query planning each time that+ When this parameter is <literal>true</literal>, <literal>pg_plan_advice</literal>+ will print messages during query planning each time that
<literal>pg_plan_advice</literal> alters the mask of allowable query
plan types in response to supplied plan advice. The default value is
<literal>false</literal>. The messages printed by this setting are not
diff --git a/doc/src/sgml/pgstashadvice.sgml b/doc/src/sgml/pgstashadvice.sgmlindex 7813d63d91e..bee31fcc58b 100644--- a/doc/src/sgml/pgstashadvice.sgml+++ b/doc/src/sgml/pgstashadvice.sgml@@ -58,7 +58,7 @@
show the query ID, and the <literal>PLAN_ADVICE</literal> option will
show plan advice. Query identifiers can also be obtained through tools
such as <xref linkend="pgstatstatements" /> or
- <xref linkend="monitoring-pg-stat-activity-view" />, but these tools+ <link linkend="monitoring-pg-stat-activity-view">pg_stat_activity</link>, but these tools
will not provide plan advice strings. Note that
<xref linkend="guc-compute-query-id" /> must be enabled for query
identifiers to be computed; if set to <literal>auto</literal>, loading
@@ -102,7 +102,7 @@
<listitem>
<para>
- Creates a new, empty advice stash with the given name.+ Creates a new empty advice stash with the given name.
</para>
</listitem>
</varlistentry>
diff --git a/doc/src/sgml/protocol.sgml b/doc/src/sgml/protocol.sgmlindex 8ced69f283b..aba34a82133 100644--- a/doc/src/sgml/protocol.sgml+++ b/doc/src/sgml/protocol.sgml@@ -6184,7 +6184,7 @@ psql "dbname=postgres replication=database" -c "IDENTIFY_SYSTEM;"
<para>
The protocol version number. The most significant 16 bits are
the major version number. The least significant 16 bits are the minor
- version number. As an example protocol version 3.2 is represented as+ version number. As an example, protocol version 3.2 is represented as
<literal>196610</literal> in decimal or more clearly as
<literal>0x00030002</literal> in hexadecimal.
</para>
diff --git a/doc/src/sgml/ref/alter_publication.sgml b/doc/src/sgml/ref/alter_publication.sgmlindex 86bdc98fd09..6f79b2d39e2 100644--- a/doc/src/sgml/ref/alter_publication.sgml+++ b/doc/src/sgml/ref/alter_publication.sgml@@ -127,7 +127,7 @@ ALTER PUBLICATION <replaceable class="parameter">name</replaceable> RENAME TO <r
Adding a table to a publication additionally requires owning that table.
The <literal>ADD TABLES IN SCHEMA</literal>,
<literal>SET TABLES IN SCHEMA</literal>, <literal>SET ALL TABLES</literal>,
- and <literal>SET ALL SEQUENCES</literal> to a publication requires the+ and <literal>SET ALL SEQUENCES</literal> to a publication require the
invoking user to be a superuser.
To alter the owner, you must be able to <literal>SET ROLE</literal> to the
new owning role, and that role must have <literal>CREATE</literal>
diff --git a/doc/src/sgml/ref/alter_subscription.sgml b/doc/src/sgml/ref/alter_subscription.sgmlindex 545264e8a0a..37ba3fd2d9f 100644--- a/doc/src/sgml/ref/alter_subscription.sgml+++ b/doc/src/sgml/ref/alter_subscription.sgml@@ -181,7 +181,7 @@ ALTER SUBSCRIPTION <replaceable class="parameter">name</replaceable> RENAME TO <
<para>
The system catalog <link linkend="catalog-pg-subscription-rel">pg_subscription_rel</link>
- is updated to record all tables and sequences known to the subscription,+ is updated to record all tables and sequences known to the subscription
that are still part of the publication.
</para>
diff --git a/doc/src/sgml/ref/create_publication.sgml b/doc/src/sgml/ref/create_publication.sgmlindex 8196e6a4235..0b03a6a62ab 100644--- a/doc/src/sgml/ref/create_publication.sgml+++ b/doc/src/sgml/ref/create_publication.sgml@@ -203,7 +203,7 @@ CREATE PUBLICATION <replaceable class="parameter">name</replaceable>
<para>
Marks the publication as one that replicates changes for all tables in
the database, including tables created in the future. Tables listed in
- <literal>EXCEPT</literal> clause are excluded from the publication.+ the <literal>EXCEPT</literal> clause are excluded from the publication.
</para>
</listitem>
</varlistentry>
@@ -249,7 +249,7 @@ CREATE PUBLICATION <replaceable class="parameter">name</replaceable>
For partitioned tables, only the root partitioned table may be specified
in <literal>EXCEPT</literal>. Doing so excludes the root table and
all of its partitions from replication. The optional
- <literal>ONLY</literal> and <literal>*</literal> has no effect for+ <literal>ONLY</literal> and <literal>*</literal> have no effect for
partitioned tables.
</para>
<para>
diff --git a/doc/src/sgml/ref/pg_createsubscriber.sgml b/doc/src/sgml/ref/pg_createsubscriber.sgmlindex 193f60628bc..5d501147608 100644--- a/doc/src/sgml/ref/pg_createsubscriber.sgml+++ b/doc/src/sgml/ref/pg_createsubscriber.sgml@@ -153,14 +153,14 @@ PostgreSQL documentation
<itemizedlist>
<listitem>
<para>
- <filename>pg_createsubscriber_server.log</filename> which captures logs+ <filename>pg_createsubscriber_server.log</filename>, which captures logs
related to stopping and starting the standby server,
</para>
</listitem>
<listitem>
<para>
- <filename>pg_createsubscriber_internal.log</filename> which captures- internal diagnostic output (validations, checks, etc.)+ <filename>pg_createsubscriber_internal.log</filename>, which captures+ internal diagnostic output (validations, checks, etc.).
</para>
</listitem>
</itemizedlist>
@@ -327,7 +327,7 @@ PostgreSQL documentation
If a specified publication already exists on the publisher, it is reused.
It is useful to partially replicate the database if the specified
publication includes a list of tables. If the publication does not exist,
- it is automatically created with <literal>FOR ALL TABLES</literal>. Use+ it is automatically created with <literal>FOR ALL TABLES</literal>. Use the
<option>--dry-run</option> option to preview which publications will be
reused and which will be created.
</para>
@@ -575,7 +575,7 @@ PostgreSQL documentation
<application>pg_createsubscriber</application> terminates if recovery
does not end until the given number of seconds. Upon completion, the
included configuration file is renamed to
- <filename>pg_createsubscriber.conf.disabled</filename> so as it is no+ <filename>pg_createsubscriber.conf.disabled</filename> so that it is no
longer loaded on subsequent restarts.
</para>
</step>
diff --git a/doc/src/sgml/ref/pgarchivecleanup.sgml b/doc/src/sgml/ref/pgarchivecleanup.sgmlindex 79e751381ac..5edcac33f54 100644--- a/doc/src/sgml/ref/pgarchivecleanup.sgml+++ b/doc/src/sgml/ref/pgarchivecleanup.sgml@@ -23,8 +23,8 @@ PostgreSQL documentation
<cmdsynopsis>
<command>pg_archivecleanup</command>
<arg rep="repeat"><replaceable>option</replaceable></arg>
- <arg choice="plain"><replaceable>archivelocation</replaceable></arg>- <arg choice="plain"><replaceable>oldestkeptwalfile</replaceable></arg>+ <arg choice="plain"><replaceable>archive_location</replaceable></arg>+ <arg choice="plain"><replaceable>oldest_kept_wal_file</replaceable></arg>
</cmdsynopsis>
</refsynopsisdiv>
@@ -44,28 +44,28 @@ PostgreSQL documentation
server to use <application>pg_archivecleanup</application>, put this into its
<filename>postgresql.conf</filename> configuration file:
<programlisting>
-archive_cleanup_command = 'pg_archivecleanup <replaceable>archivelocation</replaceable> "%r"'+archive_cleanup_command = 'pg_archivecleanup <replaceable>archive_location</replaceable> "%r"'
</programlisting>
- where <replaceable>archivelocation</replaceable> is the directory from which WAL segment+ where <replaceable>archive_location</replaceable> is the directory from which WAL segment
files should be removed.
</para>
<para>
When used within <xref linkend="guc-archive-cleanup-command"/>, all WAL files
logically preceding the value of the <literal>%r</literal> argument will be removed
- from <replaceable>archivelocation</replaceable>. This minimizes the number of files+ from <replaceable>archive_location</replaceable>. This minimizes the number of files
that need to be retained, while preserving crash-restart capability. Use of
- this parameter is appropriate if the <replaceable>archivelocation</replaceable> is a+ this parameter is appropriate if the <replaceable>archive_location</replaceable> is a
transient staging area for this particular standby server, but
- <emphasis>not</emphasis> when the <replaceable>archivelocation</replaceable> is intended as a+ <emphasis>not</emphasis> when the <replaceable>archive_location</replaceable> is intended as a
long-term WAL archive area, or when multiple standby servers are recovering
from the same archive location.
</para>
<para>
When used as a standalone program all WAL files logically preceding the
- <replaceable>oldestkeptwalfile</replaceable> will be removed from <replaceable>archivelocation</replaceable>.+ <replaceable>oldest_kept_wal_file</replaceable> will be removed from <replaceable>archive_location</replaceable>.
In this mode, if you specify a <filename>.partial</filename> or <filename>.backup</filename>
file name, then only the file prefix will be used as the
- <replaceable>oldestkeptwalfile</replaceable>. This treatment of <filename>.backup</filename>+ <replaceable>oldest_kept_wal_file</replaceable>. This treatment of <filename>.backup</filename>
file name allows you to remove
all WAL files archived prior to a specific base backup without error.
For example, the following example will remove all files older than
@@ -80,7 +80,7 @@ pg_archivecleanup: removing file "archive/00000001000000370000000E"
</para>
<para>
<application>pg_archivecleanup</application> assumes that
- <replaceable>archivelocation</replaceable> is a directory readable and writable by the+ <replaceable>archive_location</replaceable> is a directory readable and writable by the
server-owning user.
</para>
</refsect1>
diff --git a/doc/src/sgml/ref/pgbench.sgml b/doc/src/sgml/ref/pgbench.sgmlindex 9688527c955..d941451c15e 100644--- a/doc/src/sgml/ref/pgbench.sgml+++ b/doc/src/sgml/ref/pgbench.sgml@@ -815,7 +815,7 @@ pgbench <optional> <replaceable>options</replaceable> </optional> <replaceable>d
<para>deadlock failures;</para>
</listitem>
<listitem>
- <para>other failures;</para>+ <para>other failures.</para>
</listitem>
</itemizedlist>
See <xref linkend="failures-and-retries"/> for more information.
diff --git a/doc/src/sgml/ref/pgtesttiming.sgml b/doc/src/sgml/ref/pgtesttiming.sgmlindex 285f27f7c31..c450078291b 100644--- a/doc/src/sgml/ref/pgtesttiming.sgml+++ b/doc/src/sgml/ref/pgtesttiming.sgml@@ -162,7 +162,7 @@ PostgreSQL documentation
instruction (used for <command>EXPLAIN ANALYZE</command>). At the end
of the output, the <acronym>TSC</acronym> frequency, which may either be
sourced from CPU information directly, or the alternate calibration
- mechanism are shown, as well as whether the <acronym>TSC</acronym> clock+ mechanism is shown, as well as whether the <acronym>TSC</acronym> clock
source will be used by default.
</para>
diff --git a/doc/src/sgml/runtime.sgml b/doc/src/sgml/runtime.sgmlindex d9984910cc4..69b349d54f6 100644--- a/doc/src/sgml/runtime.sgml+++ b/doc/src/sgml/runtime.sgml@@ -2604,8 +2604,8 @@ openssl x509 -req -in server.csr -text -days 365 \
<productname>PostgreSQL</productname> can be configured for Server Name
Indication, <acronym>SNI</acronym>, using the <xref linkend="guc-ssl-sni"/>
configuration parameter. <productname>PostgreSQL</productname> inspects the
- TLS hostname extension in the SSL connection handshake, and selects the- right certificate, key and CA certificate to use for the connection based+ TLS hostname extension in the SSL connection handshake and selects the+ right certificate, key, and CA certificate to use for the connection based
on entries in the <xref linkend="guc-hosts-file"/> configuration file.
</para>
@@ -2665,8 +2665,8 @@ openssl x509 -req -in server.csr -text -days 365 \
<entry>Required</entry>
<entry>
Certificate and key to use for connections to the host specified in
- the connection. Multiple hostnames can be defined by using a comma- separated list. The certificate and key will be used for connections+ the connection. Multiple hostnames can be defined by using a+ comma-separated list. The certificate and key will be used for connections
to all hosts in the list.
</entry>
</row>
diff --git a/doc/src/sgml/system-views.sgml b/doc/src/sgml/system-views.sgmlindex 77202e2c765..45862ae5a1e 100644--- a/doc/src/sgml/system-views.sgml+++ b/doc/src/sgml/system-views.sgml@@ -1167,7 +1167,7 @@ AND c1.path[c2.level] = c2.path[c2.level];
<structfield>type</structfield> <type>text</type>
</para>
<para>
- The type of allocation. Possible values are <literal>segment</literal>,+ The type of the allocation. Possible values are <literal>segment</literal>,
<literal>area</literal>, and <literal>hash</literal>, which correspond
to dynamic shared memory segments, areas, and hash tables, respectively.
</para></entry>
@@ -1178,7 +1178,7 @@ AND c1.path[c2.level] = c2.path[c2.level];
<structfield>size</structfield> <type>int8</type>
</para>
<para>
- Size of the allocation in bytes. NULL for entries that failed+ The size of the allocation in bytes. NULL for entries that failed
initialization.
</para></entry>
</row>
@@ -4232,7 +4232,7 @@ SELECT * FROM pg_locks pl LEFT JOIN pg_prepared_xacts ppx
<structfield>size</structfield> <type>int8</type>
</para>
<para>
- Size of the allocation in bytes+ The size of the allocation in bytes.
</para></entry>
</row>
@@ -4241,7 +4241,7 @@ SELECT * FROM pg_locks pl LEFT JOIN pg_prepared_xacts ppx
<structfield>allocated_size</structfield> <type>int8</type>
</para>
<para>
- Size of the allocation in bytes including padding. For anonymous+ The size of the allocation in bytes including padding. For anonymous
allocations, no information about padding is available, so the
<literal>size</literal> and <literal>allocated_size</literal> columns
will always be equal. Padding is not meaningful for free memory, so
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-docs@postgresql.org
Cc: o.sibiryakov@postgrespro.ru, pgsql-docs@lists.postgresql.org
Subject: Re: Documentation improvement patch
In-Reply-To: <ba30ee2f-d6f3-4116-8c2b-c353a84b5cc8@postgrespro.ru>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox