pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Tom Lane <tgl@sss.pgh.pa.us>
To: Andres Freund <andres@anarazel.de>
Cc: Peter Eisentraut <peter.eisentraut@enterprisedb.com>
Cc: Michael Paquier <michael@paquier.xyz>
Cc: Justin Pryzby <pryzby@telsasoft.com>
Cc: pgsql-hackers@postgresql.org
Subject: Re: pg_upgrade test writes to source directory
Date: Tue, 16 Aug 2022 10:58:16 -0400
Message-ID: <1131990.1660661896@sss.pgh.pa.us> (raw)
In-Reply-To: <20220816032051.ya7ieuteaq2h6g2m@awork3.anarazel.de>
References: <YpAMBqPrusng47e0@paquier.xyz>
	<2480063.1653609068@sss.pgh.pa.us>
	<YpAV1y8CUXGGkPJQ@paquier.xyz>
	<20220528195949.tte5fukfr2z6xhrr@alap3.anarazel.de>
	<3131727.1653768841@sss.pgh.pa.us>
	<YpXA7XHZtunxalTr@paquier.xyz>
	<e65a862a-24aa-7482-6d98-49fbb048f22f@enterprisedb.com>
	<571133.1654095328@sss.pgh.pa.us>
	<20220811152028.znxm5fpxjhe43hzw@awork3.anarazel.de>
	<11298.1660231599@sss.pgh.pa.us>
	<20220816032051.ya7ieuteaq2h6g2m@awork3.anarazel.de>

Andres Freund <andres@anarazel.de> writes:
> On 2022-08-11 11:26:39 -0400, Tom Lane wrote:
>> Given that it's no longer going to be the same tmp_check dir used
>> elsewhere, maybe we could s/tmp_check/tab_comp_dir/g or something
>> like that?  That'd add some clarity I think.

> Done in the attached patch (0001).

I was confused by 0001, because with the present test setup that will
result in creating an extra tab_comp_dir that isn't inside tmp_check,
leading to needing cleanup infrastructure that isn't there.  However,
0002 clarifies that: you're redefining TESTDIR.  I think 0001 is OK
as long as you apply it after, or integrate it into, 0002.

> patch 0002 just moves the addition of /tmp_check from Utils.pm to the places
> in which TESTDIR is defined.

I see some references to TESTDIR in src/tools/msvc/ecpg_regression.proj.
It looks like those are not references to this variable but uses of the

 <PropertyGroup>
  <TESTDIR>..\..\interfaces\ecpg\test</TESTDIR>

thingy at the top of the file.  Still, it's a bit confusing --- should
we rename that?  Maybe not worth the trouble given the short expected
lifespan of the MSVC test scripts.  0002 seems fine otherwise.

> I've also attached a 0003 that splits the log location from the data
> location. That could be used to make the log file location symmetrical between
> pg_regress (log/) and tap tests (tmp_check/log).  But it'd break the
> buildfarm's tap test log file collection, so I don't think that's something we
> really can do soon-ish?

No particular opinion about 0003 -- as you say, that's going to be
gated by the buildfarm.

			regards, tom lane





view thread (31+ messages)  latest in thread

Message-ID: <1131990.1660661896@sss.pgh.pa.us>
Permalink:  ../1131990.1660661896@sss.pgh.pa.us/
Also on:    postgresql.org/message-id/1131990.1660661896@sss.pgh.pa.us

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: tgl@sss.pgh.pa.us, andres@anarazel.de, peter.eisentraut@enterprisedb.com, michael@paquier.xyz, pryzby@telsasoft.com
  Subject: Re: pg_upgrade test writes to source directory
  In-Reply-To: <1131990.1660661896@sss.pgh.pa.us>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox