pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: David Geier <geidav.pg@gmail.com>
To: Tom Lane <tgl@sss.pgh.pa.us>
Cc: Chao Li <li.evan.chao@gmail.com>
Cc: pgsql-hackers <pgsql-hackers@postgresql.org>
Subject: Re: Consistently use palloc_object() and palloc_array()
Date: Fri, 28 Nov 2025 22:47:08 +0100
Message-ID: <1e7f0c17-a965-4d5b-ad88-b435a4d97490@gmail.com> (raw)
In-Reply-To: <524587.1764365323@sss.pgh.pa.us>
References: <ad0748d4-3080-436e-b0bc-ac8f86a3466a@gmail.com>
	<ED821EDD-6A1B-45B8-9005-31BCFFCB5A48@gmail.com>
	<a29b0cd9-576f-486f-ba45-5139ee33adcf@gmail.com>
	<524587.1764365323@sss.pgh.pa.us>

On 28.11.2025 22:28, Tom Lane wrote:
> David Geier <geidav.pg@gmail.com> writes:
>> On 27.11.2025 00:03, Chao Li wrote:
>>> This is a large patch, I just take a quick look, and found that:
>>> -		*phoned_word = palloc(sizeof(char) * strlen(word) + 1);
>>> +		*phoned_word = palloc_array(char, strlen(word) + 1);
>>> And
>>> -		params = (const char **) palloc(sizeof(char *));
>>> +		params = palloc_object(const char *);
>>> Applying palloc_array and palloc_object to char type doesn’t seem to improve anything.
> 
>> You mean because sizeof(char) is always 1 and hence we could instead
>> simply write:
>> 		*phoned_word = palloc(strlen(word) + 1);
>> 		params = palloc(1);
>> I think the _array and _object variants are more expressive and for sure
>> don't make the code less readable.
> 
> Yeah, I agree these particular changes seem fine.  When you're doing
> address arithmetic for a memcpy or such, it may be fine to wire in an
> assumption that sizeof(char) == 1, but I think doing that in other
> contexts is not particularly good style.
> 
> Another thing to note is that the proposed patch effectively changes
> the expression evaluation order:
> 
> -		*phoned_word = palloc((sizeof(char) * strlen(word)) + 1);
> +		*phoned_word = palloc(sizeof(char) * (strlen(word) + 1));
> 
> Now, there's not actually any difference because sizeof(char) is 1,
> but if it hypothetically weren't, the new version is likely more
> correct.  Presumably the +1 is meant to allow room for a trailing \0,
> which is a char.

Oh right. Good catch!

> It'd be a good idea to review the patch to see if there are any
> places where semantics are changed in a less benign fashion...

I intentionally tried to avoid any semantic changes but it's of course
possible something slipped through by accident.

It's some ~1700 occurrences in the patch. If it takes ~10 seconds to
check a single, it would take ~4.7h to review the entire patch.

If no one is willing to take this on, I could split up the patch in 4 to
5 that each can be reviewed by someone else.

--
David Geier





view thread (29+ messages)  latest in thread

Message-ID: <1e7f0c17-a965-4d5b-ad88-b435a4d97490@gmail.com>
Permalink:  ../1e7f0c17-a965-4d5b-ad88-b435a4d97490@gmail.com/
Also on:    postgresql.org/message-id/1e7f0c17-a965-4d5b-ad88-b435a4d97490@gmail.com

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: geidav.pg@gmail.com, tgl@sss.pgh.pa.us, li.evan.chao@gmail.com
  Subject: Re: Consistently use palloc_object() and palloc_array()
  In-Reply-To: <1e7f0c17-a965-4d5b-ad88-b435a4d97490@gmail.com>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox