pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Alvaro Herrera from 2ndQuadrant <alvherre@alvh.no-ip.org>
To: Masahiko Sawada <sawada.mshk@gmail.com>
Cc: Michael Paquier <michael@paquier.xyz>
Cc: Amit Kapila <amit.kapila16@gmail.com>
Cc: Craig Ringer <craig@2ndquadrant.com>
Cc: Ashutosh Sharma <ashu.coek88@gmail.com>
Cc: Julien Rouhaud <rjuju123@gmail.com>
Cc: Peter Geoghegan <pg@bowt.ie>
Cc: PostgreSQL Hackers <pgsql-hackers@postgresql.org>
Cc: Abhijit Menon-Sen <ams@2ndquadrant.com>
Cc: Peter Eisentraut <peter.eisentraut@2ndquadrant.com>
Cc: Pavan Deolasee <pavan.deolasee@2ndquadrant.com>
Subject: Re: [HACKERS] [PATCH] pageinspect function to decode infomasks
Date: Wed, 11 Sep 2019 12:29:57 -0300
Message-ID: <20190911152957.GA24327@alvherre.pgsql> (raw)
In-Reply-To: <CAD21AoDSn0q+G6mLofEQSJvrw4yYo0R_uh7kM3tm+YGcnupp4A@mail.gmail.com>

On 2019-Sep-11, Masahiko Sawada wrote:

> On Wed, Sep 11, 2019 at 1:46 PM Michael Paquier <michael@paquier.xyz> wrote:
> >
> > On Tue, Sep 10, 2019 at 08:29:43AM +0530, Amit Kapila wrote:
> > > Good thought, but I think even if we want to change the name of
> > > tuple_data_split, it might be better done separately.
> >
> > Yes, that's not the problem of this patch.  Not sure if it actually
> > makes sense either to change it.
> 
> Hmm it will be more consistent with other functions but I think we
> would need to increase the pageinspect version to 1.8 and need the new
> sql file to rename the function name. And it will be for PG12, not
> PG13. If we have to do it someday I think it's better to do it in PG12
> that the table AM has been introduced to. Anyway I've attached
> separate patch for it.

I'd rather not change the name of the existing function ... that
function is pretty old (it was introduced in 9.6, commit d6061f83a166).
I think we can regard that name as an historical accident, and use a
modern name convention for the new function (and any hypothetical future
ones) that will, sadly, collide with the historical name for the old
function.

-- 
Álvaro Herrera                https://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services





view thread (82+ messages)  latest in thread

Message-ID: <20190911152957.GA24327@alvherre.pgsql>
Permalink:  ../20190911152957.GA24327@alvherre.pgsql/
Also on:    postgresql.org/message-id/20190911152957.GA24327@alvherre.pgsql

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: alvherre@alvh.no-ip.org, sawada.mshk@gmail.com, michael@paquier.xyz, amit.kapila16@gmail.com, craig@2ndquadrant.com, ashu.coek88@gmail.com, rjuju123@gmail.com, pg@bowt.ie, ams@2ndquadrant.com, peter.eisentraut@2ndquadrant.com, pavan.deolasee@2ndquadrant.com
  Subject: Re: [HACKERS] [PATCH] pageinspect function to decode infomasks
  In-Reply-To: <20190911152957.GA24327@alvherre.pgsql>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox