From: Alvaro Herrera <alvherre@2ndquadrant.com>
To: Kyotaro Horiguchi <horikyota.ntt@gmail.com>
Cc: amit.kapila16@gmail.com
Cc: masao.fujii@oss.nttdata.com
Cc: michael@paquier.xyz
Cc: pgsql-hackers@lists.postgresql.org
Subject: Re: min_safe_lsn column in pg_replication_slots view
Date: Tue, 7 Jul 2020 13:48:00 -0400
Message-ID: <20200707174800.GA17240@alvherre.pgsql> (raw)
In-Reply-To: <20200707030133.GA29468@alvherre.pgsql>
On 2020-Jul-06, Alvaro Herrera wrote:
> On 2020-Jul-07, Kyotaro Horiguchi wrote:
> > Couldn't we move ConvertToXSegs from xlog.c to xlog_ingernals.h and
> > use it intead of the bare expression?
>
> I was of two minds about that, and the only reason I didn't do it is
> that we'll need to give it a better name if we do it ... I'm open to
> suggestions.
In absence of other suggestions I gave this the name XLogMBVarToSegs,
and redefined ConvertToXSegs to use that. Didn't touch callers in
xlog.c to avoid pointless churn. Pushed to both master and 13.
I hope this satisfies everyone ... Masao-san, thanks for reporting the
problem, and thanks Horiguchi-san for providing the fix. (Also thanks
to Amit and Michael for discussion.)
--
Álvaro Herrera https://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: alvherre@2ndquadrant.com, horikyota.ntt@gmail.com, amit.kapila16@gmail.com, masao.fujii@oss.nttdata.com, michael@paquier.xyz, pgsql-hackers@lists.postgresql.org
Subject: Re: min_safe_lsn column in pg_replication_slots view
In-Reply-To: <20200707174800.GA17240@alvherre.pgsql>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox