public inbox for [email protected]  
help / color / mirror / Atom feed
From: Nathan Bossart <[email protected]>
To: Robert Haas <[email protected]>
Cc: Michael Paquier <[email protected]>
Cc: [email protected] <[email protected]>
Subject: Re: pgsql: Rename contrib module basic_archive to basic_wal_module
Date: Wed, 25 Jan 2023 10:17:50 -0800
Message-ID: <20230125181750.GC1098626@nathanxps13> (raw)
In-Reply-To: <CA+TgmoYG5uGOp7DGFT5gzC1kKFWGjkLSj_wOQxGhfMcvVEiKGA@mail.gmail.com>
References: <[email protected]>
	<CA+TgmoYG5uGOp7DGFT5gzC1kKFWGjkLSj_wOQxGhfMcvVEiKGA@mail.gmail.com>

On Wed, Jan 25, 2023 at 12:49:45PM -0500, Robert Haas wrote:
> On Wed, Jan 25, 2023 at 12:37 AM Michael Paquier <[email protected]> wrote:
>> Rename contrib module basic_archive to basic_wal_module
> 
> FWIW, I find this new name much less clear than the old one.
> 
> If we want to provide a basic_archive module and a basic_recovery
> module, that seems fine. Why merge them?

I'll admit I've been stewing on whether "WAL Modules" is the right name.
My first instinct was to simply call it "Archive and Recovery Modules,"
which is longer but (IMHO) clearer.

I wanted to merge basic_archive and basic_recovery because there's a decent
chunk of duplicated code.  Perhaps that is okay, but I would rather just
have one test module.  AFAICT the biggest reason to split it is because we
can't determine a good name.  Maybe we could leave the name as
"basic_archive" since it deals with creating and recovering archive files.

-- 
Nathan Bossart
Amazon Web Services: https://aws.amazon.com






view thread (2+ messages)

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: [email protected]
  Cc: [email protected], [email protected], [email protected]
  Subject: Re: pgsql: Rename contrib module basic_archive to basic_wal_module
  In-Reply-To: <20230125181750.GC1098626@nathanxps13>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox